On Wed, Mar 11, 2009 at 1:52 PM, Dan Korostelev <[email protected]> wrote:
> 2009/3/11 Martijn Faassen <[email protected]>:
>
>> You should write up a short description of what zope.principalregistry
>> does. In fact whenever we propose a new package we should describe its
>> "mission statement" in just a couple of lines. That'll help us think
>> about it better.
>
> I'll add a short README.txt to each package. The
> zope.principalregistry is an non-persistent implementation of
> IAuthentication that allows us to define principals via zcml (the
> "principal" directive and company) or with simple python calls. It's
> also quite useful for tests.
<bikeshed>
Maybe we can use the "description" or "long_description" field
in the setup.py for the "package mission statement"
</bikeshed>
--
Benji York
Senior Software Engineer
Zope Corporation
_______________________________________________
Zope-Dev maillist - [email protected]
http://mail.zope.org/mailman/listinfo/zope-dev
** No cross posts or HTML encoding! **
(Related lists -
http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )