Chris Withers wrote:
> Paul Winkler wrote:
>> Well, yeah. The point of the suggestion was specifically to help you
>> get more info about the dependency chain, since pip is more verbose
>> about that than easy_install is.
> Well, running buildout -vvvvv gives some good clues, a piece of which is 
> this:
> Getting required ''
>    required by 3.5.1.
>    required by 3.6.0.
>    required by 3.6.0.
> We have the best distribution that satisfies ''.
> Picked: = 3.7.0
> Okay, cute, but WHY is 3.7.0 being picked, rather than the 3.6.0 that's 
> nailed down in zope2 2.12.0a1's!

Off the back of this, I changed the buildout.cfg to be the following:
parts = zopetest
versions = versions


recipe = zc.recipe.egg
interpreter = py
eggs =

...and we got much further. So, this has gotta be a buildout bug, right?



PS: Even with the above, the next barf is:

Error: There is a version conflict.
We already have: zope.component 3.5.1
but zope.authentication 3.7.0 requires 'zope.component>=3.6.0'.

Interestingly, zope.authentication *isn't* listed in zope2 2.12.0a1's 
setup.y. I guess it should be?
Zope-Dev maillist  -
**  No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to