It would be possible to modify the plonectl script in order to make it run
without using the zdaemon? Similar to way that the runzope used to work.

I am using the Plone unified installer, it doesn't comes with the runzope
script.

Thanks,
Cesar

2009/3/29 Dieter Maurer <die...@handshake.de>

> Cesar Canassa wrote at 2009-3-27 19:56 -0300:
> >Does Zope requires that a "root" user should exist on system in order to
> run
> >properly? I am asking this because when I try to run Zope as a daemon I
> got
> >this:
> >
> >$ ./plonectl start
> >instance: . . . . . . . . . . . . . . . . . . . Unlinking stale socket
> >/cygdrive/c/Cygwin/home/ccanassa/Plone/zinstance/var/instance/zopectlsock;
> >sleep 1
> >
> >No handlers could be found for logger "root"
> >. Unlinking stale socket
> >/cygdrive/c/Cygwin/home/ccanassa/Plone/zinstance/var/instance/zopectlsock;
> >sleep 1
> >. Unlinking stale socket
>
> The continued "Unlinking stale socket" means that your "zdaemon" is dieing.
>
>
> "zdaemon" is not supposed to work under Windows.
>
> I am unsure whether this also includes "Cygwin on Windows".
> Your observation may indicate that it actually does....
>
>
> Try to configure logging for your "zdaemon" and look into its logfile.
> If this does not reveal hints, modify the "zdaemon" code to ensure
> that problems are logged to a file you know.
>
>
> --
> Dieter
>
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to