Hi Andreas,

I tried it with virtualenv --no-site-packages foo and it works.

Excuse the false alarm.

Peter


>
>> I just created a new Zope 2.12.0a4 that should easy_install nicely.
>> Howto?
>> virtualenv foo
>> cd foo
>> source bin/activate
>> bin/easy_install -i http://download.zope.org/Zope2/index/2.12.0a4  
>> Zope2
>> Please give feedback.
>
> On python2.5/gentoo/ppc I got this:
>
> t001 $ ./bin/mkzopeinstance Traceback (most recent call last):
> File "./bin/mkzopeinstance", line 8, in <module>
>   load_entry_point('Zope2==2.12.0a4', 'console_scripts',  
> 'mkzopeinstance')()
> File "/home/peter/9002/t001/lib/python2.5/site- packages/ 
> setuptools-0.6c9-py2.5.egg/pkg_resources.py", line 277, in  
> load_entry_point
> File "/home/peter/9002/t001/lib/python2.5/site- packages/ 
> setuptools-0.6c9-py2.5.egg/pkg_resources.py", line 2180, in  
> load_entry_point
> File "/home/peter/9002/t001/lib/python2.5/site- packages/ 
> setuptools-0.6c9-py2.5.egg/pkg_resources.py", line 1913, in load
> File "/home/peter/9002/t001/lib/python2.5/site- packages/ 
> Zope2-2.12.0a4-py2.5-linux-ppc.egg/Zope2/__init__.py", line 60, in  
> <module>
>   from Zope2.Startup.run import configure
> File "/home/peter/9002/t001/lib/python2.5/site- packages/ 
> Zope2-2.12.0a4-py2.5-linux-ppc.egg/Zope2/Startup/__init__.py", line  
> 34, in <module>
>   from zope.app import appsetup
> File "/home/peter/9002/t001/lib/python2.5/site-packages/ 
> zope.app.appse tup-3.9.0-py2.5.egg/zope/app/appsetup/__init__.py",  
> line 22, in <module>
>   from zope.app.appsetup.appsetup import config, database
> File "/home/peter/9002/t001/lib/python2.5/site-packages/ 
> zope.app.appse tup-3.9.0-py2.5.egg/zope/app/appsetup/appsetup.py",  
> line 24, in <module>
>   import zope.site.hooks
> File "/home/peter/9002/t001/lib/python2.5/site- packages/ 
> zope.site-3.6.1-py2.5.egg/zope/site/__init__.py", line 19, in <module>
>   from zope.site.site import (SiteManagerContainer,  
> SiteManagementFolder,
> File "/home/peter/9002/t001/lib/python2.5/site- packages/ 
> zope.site-3.6.1-py2.5.egg/zope/site/site.py", line 31, in <module>
>   import zope.component.persistentregistry
> File "/home/peter/9002/t001/lib/python2.5/site-packages/ 
> zope.component -3.5.1-py2.5.egg/zope/component/ 
> persistentregistry.py", line 25, in <module>
>   zope.interface.adapter.VerifyingAdapterRegistry,
> AttributeError: 'module' object has no attribute  
> 'VerifyingAdapterRegistry'


_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to