Following just happened. The project has KGS 3.4 versions as a base,
locally I wanted to override lxml to >= 2.1.1.

extends = http://download.zope.org/zope3.4/3.4.0/versions.cfg
versions = versions

lxml >= 2.1.1

The bin/buildout -vvvvv output was:
Installing 'zc.buildout', 'setuptools'.
We have the distribution that satisfies 'zc.buildout==1.1.1'.
We have the distribution that satisfies 'setuptools==0.6c9'.
Configuration data:
lxml = 1.3.6
lxml > = 2.1.1
Getting required 'lxml==1.3.6'
We have the distribution that satisfies 'lxml==1.3.6'.

I thought the local [versions] would override the inherited ones?
If I put
lxml = 2.1.1
buildout nicely picks 2.1.1

Is this a bug?

Best regards,
 Adam GROSZER                          mailto:agros...@gmail.com
Quote of the day:
Time is nature's way of making sure that everything doesn't happen at once.

Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to