Previously Martijn Faassen wrote:
> Wichert Akkerman wrote:
> > Previously Martijn Faassen wrote:
> >> I propose we use the word 'Locus' instead of 'Site'. This word doesn't 
> >> have a lot of connotations in the web programming world, and people can 
> >> guess by simply looking at the word it might have something to do with 
> >> *local* components. It's also short.
> > 
> > I don't see short as a very important quality here. It is not a name you
> > have to type in often, so I would prefer something more descriptive. How
> > about "componentroot" or "componentcontainer"..
> I do find short an important quality here, because I find myself typing 
> "getSite()" frequently, and in tests, "setSite" as well. It's also 
> something one talks about.

People also talk about www which is horrible to pronounce in English :)

> A site isn't a container, I'll note. A site is something that has local 
> components registered but doesn't need to be implemented as a container 
> at all.

A site contains component registraties and possible persistent
components. That makes it a container to me.

Perhaps componentRegistry works better for you?


Wichert Akkerman <>    It is simple to make things.                   It is hard to make things simple.
Zope-Dev maillist  -
**  No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to