On Jul 2, 2009, at 7:58 AM, Hanno Schlichting wrote:

> On Thu, Jul 2, 2009 at 12:30 PM, Jim Fulton<j...@zope.com> wrote:
>> zope.app.module provides support for persistemt modules.
>> zope.app.interface provides support for persistent interfaces. Both
>> rely on a highly experimental zodbcode.  I don't have a problem with
>> these being projects, but I don't think they should be in the KGS.  I
>> don't think we should commit to supporting them, at least not as part
>> of the KGS. Does anyone disagree?
> +10 on removing those from the KGS.
> Right now both zope.app.zapi

This was deprecated a long time ago.

I think we should remove it from the kgs.  Is anyone using it?

> and zope.app.zcmlfiles still have a hard
> dependency on zope.app.interface though.

I don't think zope.app.zcml files should be in it either.  It was  
intended as a bridge to get us from teh monolith world to the new  
world.  Perhaps zope.app.zcml files should become a sort of meta  
package for some working set of the things it depends on, at some  
revision at which it worked, perhaps corresponding to the 3.4.0  


Jim Fulton
Zope Corporation

Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to