On 02/07/2009 Andreas Jung wrote:
> > On 02/07/2009 Andreas Jung wrote:
> >>> Compiling /usr/lib/zope2.11/lib/python/mechanize/_firefox3cookiejar.py ...
> >>>   File "/usr/lib/zope2.11/lib/python/mechanize/_firefox3cookiejar.py", 
> >>> line 91
> >>>     yield row
> >>> SyntaxError: 'yield' not allowed in a 'try' block with a 'finally' clause
> >>>
> >>> I also found this error in list archive logs of zope-te...@epy.co.at.
> >>>
> >>> from 'pydoc2.4 yield':
> >>>
> >>>   The yield statement is not allowed in the try clause of a try ...
> >>>   finally construct. The difficulty is that there's no guarantee the
> >>>   generator will ever be resumed, hence no guarantee that the finally
> >>>   block will ever get executed.
> >>>
> >>> and does a fix exist?
> >>>       
> >> Unlikely - and I don't think that this issue is of relevance.
> >>     
> > I believe that this bug persists in zope2.12+, so it should be fixed in
> > my eyes.
> 
> mechanize is basically a third-party module shipped with Zope. Since
> Zope 2.12 requires Python 2.5 or 2.6 there is a chance will be resolved
> automatically :)

yea, sounds reasonable. still, that means that zope2.11 uses features of
python2.5+ while it still recommends and supports only python2.4.

does this mean, that zope2.11 works and is tested with python2.5?

greetings,
 jonas
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to