I suppose that depends on your point of view.

They exception is actually saying that imp.load_dynamic is not
implemented, not that it can't load the dynamic module so I would say
in my opinion that it isn't a bug.

Rgds

Tim

On Fri, Jul 3, 2009 at 4:38 PM, Chris Withers<ch...@simplistix.co.uk> wrote:
> Tim Hoffman wrote:
>> gae/1.333250465889549129/zope/i18nmessageid/_zope_i18nmessageid_message.py",
>> line 6, in __bootstrap__
>>     imp.load_dynamic(__name__,__file__)
>>   File "/base/python_dist/lib/python2.5/py_imp.py", line 116, in load_dynamic
>>     raise NotImplementedError('This function is not supported on App 
>> Engine.')
>
> This actually feels like a bug in GAE to me... This should be an
> ImportError...
>
> Chris
>
> --
> Simplistix - Content Management, Zope & Python Consulting
>            - http://www.simplistix.co.uk
> _______________________________________________
> Zope-Dev maillist  -  zope-...@zope.org
> http://mail.zope.org/mailman/listinfo/zope-dev
> **  No cross posts or HTML encoding!  **
> (Related lists -
>  http://mail.zope.org/mailman/listinfo/zope-announce
>  http://mail.zope.org/mailman/listinfo/zope )
>
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to