Hi,

On Thu, 2009-07-02 at 10:44 -0400, Jim Fulton wrote:
> Switching to zope-dev.
> 
> On Jul 2, 2009, at 10:40 AM, Chris Withers wrote:
> 
> > Jim Fulton wrote:
> >> buildout works fine. The problem is the zope.testing test runner,  
> >> which will find tests in your eggs directory if your buildout is in  
> >> your software path.
> >
> > I'm safe from this one, since I store all my eggs in ~/buildout-eggs  
> > as specified in my ~/.buildout/default.cfg.
> >
> > However, the same problem occurs with the contents of the build  
> > directory :-(
> 
> 
> It is really rather shallow and should be easy to fix.  The issue is  
> that the test finder will descend into directories that don't have  
> __init__.py files, and shouldn't.

It was shallow after understanding it ... ;)

The test runner already tried to avoid those directories, except there
wasn't a test for this and obviously it was bound to be broken.

It's fixed on the testrunner trunk now.

Christian

-- 
Christian Theune · c...@gocept.com
gocept gmbh & co. kg · forsterstraße 29 · 06112 halle (saale) · germany
http://gocept.com · tel +49 345 1229889 7 · fax +49 345 1229889 1
Zope and Plone consulting and development

Attachment: signature.asc
Description: This is a digitally signed message part

_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to