I'd like to suggest a redesign of the IReRaiseException.

I found this when reviewing revision 103682 and stumbled over the naming
of the interfaces and that the interface only mentions a __call__ to
retrieve a fact.

IMHO this pattern smells like we should design an interface like this:

class IPublisherExceptionInfo(Interface):

    reraise = Attribute('A boolean indicating whether '
                        'this exceptionshould be reraised')

Advantage: I find it much easier to read from a conceptual level.

Disadvantage: Composition of policy by bundling *many* attributes in
this way will be harder.



Christian Theune · c...@gocept.com
gocept gmbh & co. kg · forsterstraße 29 · 06112 halle (saale) · germany
http://gocept.com · tel +49 345 1229889 0 · fax +49 345 1229889 1
Zope and Plone consulting and development
Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to