On Sun, Dec 27, 2009 at 6:55 AM, Tres Seaver <tsea...@palladion.com> wrote:
> Hanno Schlichting wrote:
>> Log message for revision 107134:
>>   Moved zope.formlib / zope.app.form integration into a separate package 
>> called five.formlib.
>
> YAY!  You rock, Hanno.

Thanks, we all did our part to get Zope2 "zope.app"-free :)

One question about the separation remains, though. When and how can we
drop the five.formlib dependency from Zope2 itself? The deprecation
warnings don't mention a release or date when they'll be gone.

But in order to get Zope2 really app-free we need to drop the direct
five.formlib dependency at some point, or we still pull things in via
transitive dependencies.

Is deprecating in 2.13 and removal in 2.14 ok? Or does anyone have a
different preference? Is it ok to backport this to 2.12?

Hanno
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to