Hi!

Tres Seaver wrote:
> Hanno Schlichting wrote:
>> But in order to get Zope2 really app-free we need to drop the direct
>> five.formlib dependency at some point, or we still pull things in via
>> transitive dependencies.
>>
>> Is deprecating in 2.13 and removal in 2.14 ok?

+1

Since it doesn't make sense to mark five.formlib and zope.app.* as 
deprecated, it would be helpful to announce that ZTK and Zope 2 
maintainers will no longer support these packages after Zope 2.12.3.

>> Or does anyone have a
>> different preference? Is it ok to backport this to 2.12?

+1 for shipping Zope 2.12.3 with five.formlib

-1 for adding new deprecation warnings in a bugfix release

> +1 to dropping it in Zope 2.13:  folks who are using it will
> just need to add one egg to their buildouts (or their install_requires)
> and adjust imports, right?  Anyway, in the interests of getting to a
> clean "runs on ZTK" label sticker on the box, "onward and upward."

Why not following the normal procedure? At some point in the past we 
decided to add formlib support to Zope 2. That's a commitment. We should 
not drop features just like that.

Zope 2.13 can still have the "runs on ZTK" label if it ships with 
additional packages.


Cheers,

        Yuppie

_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to