On Sat, Feb 20, 2010 at 04:46:18PM +0100, Hanno Schlichting wrote:
> On Sat, Feb 20, 2010 at 4:33 PM, Hermann Himmelbauer <du...@qwer.tk> wrote:
> > The problem seems to be somewhere in between SQLAlchemy and pysqlite (both
> > install, however).
> >
> > It seems it works anyway. But these errors consume quite some time (around 
> > 10
> > minutes), any idea what to do?
> The problem is caused by pysqlite. If you look at it's PyPi page as
> seen by buildout / setuptools [1] you'll notice a number of links, all
> of which will be checked and accessed by buildout / setuptools.
> Among those are for example:
> http://pysqlite.org/
> http://initd.org/pub/software/pysqlite/releases/2.3/2.3.3/
> http://oss.itsystementwicklung.de/download/pysqlite/2.4/2.4.1/
> The first one of these produces the NameError, as the domain isn't
> registered anymore. The later two resolve, but point to pages stating
> "This domain is for sale".
> The easiest way would be for the maintainer of pysqlite to remove
> these entries, by editing the old release metadata on PyPi. In your
> own buildout you can probably only work around this by using your own
> index and disallowing access to PyPi. I tried once to put in a
> find-links to the actual version I wanted and a version pin, but this
> still doesn't stop buildout to check all those links. Maybe you could
> also get this to work with a dedicated zc.recipe.egg part for pysqlite
> and an index restriction for just that part.

Alternatively, if you have Python 2.5 or newer, you can switch to the
sqlite3 module in the standard library and stop depending on pysqlite.

Marius Gedminas
http://pov.lt/ -- Zope 3 consulting and development

Attachment: signature.asc
Description: Digital signature

Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to