All four of my Zope 3.4 KGS buildbot jobs failed with this opaque error
last night:

Develop: '/var/lib/buildbot/slaves/zope-kgs/py2.5-32bit-linux/build/.'
Getting distribution for 'zope.testing>=3.6.0'.
error: Permission denied <built-in function listdir> 
An error occured when trying to install zope.testing 3.9.0. Look above this 
message for any errors that were output by easy_install.
  Getting section test.
  Initializing section test.
  Installing recipe zc.recipe.testrunner.
  Getting distribution for 'zope.testing>=3.6.0'.
Error: Couldn't install: zope.testing 3.9.0

It looks like the tarball uploaded to PyPI has incorrect and extremely
restrictive file permissions (000, i.e. none at all).

I could upload a fixed tarball to PyPI (if I could make up my mind if it should
be 3.9.0 or 3.9.1), but I'm interested in the root cause: how was the tarball

Marius Gedminas
-- -- Zope 3 consulting and development

Attachment: signature.asc
Description: Digital signature

Zope-Dev maillist  -
**  No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to