On Dec 13, 2010, at 8:00 AM, Michael Howitz wrote:

> Hi,
> I have a test section in buildout (version 1.5.2) which uses the environment 
> option to get os.environ configs into the test script.
> But the environment configuration does not show up in the generated script.
> The recipe I use is zc.recipe.testrunner 1.4.0 and Python 2.5 (virtualenv).
> When running the tests of zc.recipe.testrunner with this Python many of them 
> fail including the test for the environment option.

Not inherently surprising nor necessarily indicative of a problem in the test 
suite.  Some of the things that the test suite tests are not supported with 
virtualenv (specifically, the tests for using a system Python).  That said, the 
underlying recipe functionality should work, so the answer to the next question 

> Is it intensional that zc.recipe.testrunner does not run when using a 
> virtualenv'ed Python?


I may get a chance to investigate this over the next few weeks, but I'm afraid 
I can't promise anything.

> P.S.: The Bugtracker of this project 
> https://bugs.launchpad.net/zc.recipe.testrunner is currently disabled, so I 
> was unable to put this there.

I think I registered the project so I could make a branch of it in Launchpad.  
I'm neither the author nor the maintainer of the package.  I'm happy to 
transfer the Launchpad project to whomever makes sense.

Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to