Hello,

On Mon, 21 Mar 2011 11:53:01 -0400 you wrote:
>> Subject: FAILED : Zope Buildbot / zope2.13_win-py2.6 slave-win
>> From: jdriessen at thehealthagency.com
>> Date: Sun Mar 20 15:41:43 EDT 2011
>> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035665.html
>>
>> Subject: FAILED : Zope Buildbot / zope2.13_win-py2.7 slave-win
>> From: jdriessen at thehealthagency.com
>> Date: Sun Mar 20 15:43:55 EDT 2011
>> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035666.html
>
> These are both weird Windows build failures::
>
>   error: Setup script exited with error: Unable to find vcvarsall.bat
>   While:
>     Installing test.
>     Getting distribution for 'Acquisition==2.13.7'.
>   Error: Couldn't install: Acquisition 2.13.7

Weird, eggs should be in place. Maybe the builder got the tarball and 
uses that... Deleting the tarball should help.


>> Subject: FAILED : winbot / zc_buildout_dev py_254_win32
>> From: buildbot at winbot.zope.org
>> Date: Sun Mar 20 17:07:28 EDT 2011
>> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035690.html
>>
>> Subject: FAILED : winbot / zc_buildout_dev py_265_win32
>> From: buildbot at winbot.zope.org
>> Date: Sun Mar 20 17:07:39 EDT 2011
>> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035691.html
>>
>> Subject: FAILED : winbot / zc_buildout_dev py_265_win64
>> From: buildbot at winbot.zope.org
>> Date: Sun Mar 20 17:07:50 EDT 2011
>> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035692.html
>>
>> Subject: FAILED : winbot / zc_buildout_dev py_270_win32
>> From: buildbot at winbot.zope.org
>> Date: Sun Mar 20 17:08:00 EDT 2011
>> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035693.html
>>
>> Subject: FAILED : winbot / zc_buildout_dev py_270_win64
>> From: buildbot at winbot.zope.org
>> Date: Sun Mar 20 17:08:14 EDT 2011
>> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035694.html
>
> More weird Windows build failures::
>
>
>   c:\buildslave\zc_buildout_dev_py_254_win32\build>bin\test.exe
> - --exit-with-status -1"
>   'bin\test.exe' is not recognized as an internal or external command,
> operable program or batch file.

Bootstrap failed, it just does not exit with the right exitcode.
See:
http://winbot.zope.org/builders/zc_buildout_dev%20py_270_win32/builds/239/steps/bootstrap/logs/stdio


>> Subject: FAILED : winbot / z3c.ptcompat_py_265_32
>> From: buildbot at winbot.zope.org
>> Date: Sun Mar 20 20:04:06 EDT 2011
>> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035712.html
>>
>> Subject: FAILED : winbot / z3c.rml_py_265_32
>> From: buildbot at winbot.zope.org
>> Date: Sun Mar 20 20:23:58 EDT 2011
>> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035713.html
>>
>> Subject: FAILED : winbot / z3c.form_py_265_32
>> From: buildbot at winbot.zope.org
>> Date: Sun Mar 20 20:36:50 EDT 2011
>> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035714.html
>>
>> Subject: FAILED : winbot / z3c.coverage_py_265_32
>> From: buildbot at winbot.zope.org
>> Date: Sun Mar 20 20:56:05 EDT 2011
>> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035718.html
>>
>> Subject: FAILED : winbot / z3c.macro_py_265_32
>> From: buildbot at winbot.zope.org
>> Date: Sun Mar 20 20:57:10 EDT 2011
>> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035719.html
>>
>> Subject: FAILED : winbot / z3c.pagelet_py_265_32
>> From: buildbot at winbot.zope.org
>> Date: Sun Mar 20 21:08:18 EDT 2011
>> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035720.html
>>
>> Subject: FAILED : winbot / z3c.recipe.paster_py_265_32
>> From: buildbot at winbot.zope.org
>> Date: Sun Mar 20 21:26:39 EDT 2011
>> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035721.html
>>
>> Subject: FAILED : winbot / z3c.template_py_265_32
>> From: buildbot at winbot.zope.org
>> Date: Sun Mar 20 21:28:29 EDT 2011
>> URL: http://mail.zope.org/pipermail/zope-tests/2011-March/035722.html
>
> Can we *please* either get these tests to pass, or else kill them off?
> At a bare minimum, put all the 'zc3.*' tests into a single buildout and
> have only one failure?

No please no please.
This was Malthe, he broke those tests with the newest chameleon. Kick 
his a** if you can get him online, I already sent him an email, but it 
still looks like that.
z3c.form is definitely a prominent package that definitely needs 
testing. If I disable those tests, those problems will never get fixed.

-- 
Best regards,
  Adam GROSZER
--
Quote of the day:
Don't feed the bats tonight.
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to