-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Tres and all,

so it looks like I came over as a total jerk who rides a personal attack
on Hanno. That is of course not my intention, not at all. I am sorry for
that.

I am grateful for every improvement to the code and it looks like Hanno
did a great job. I have expressed my regret for coming over to him like
that in a personal mail to him too.

What I did raise my voice for is the kind of backwards compatibility and
dependability that keeps an old application in the game even with a new
version of Zope, without having to go in and change everything. I want
developers to keep an eye open for that, even if it's not what they need
in their own work or if they believe that Zope is dead already.

The case that some admin in some random company has this Zope
application running somewhere and wants to move it to a new server and
a new Zope version, I believe that case should not be answered with "go
and write that application from scratch on some other framework".

I also would like to insist that manage_afterAdd etc has been
undeprecated in 2.12 both in code and in the documentation
(CHANGES.txt).

I will step down from my soap box in this matter now. Whatever happens,
happens.

Regards,

Sascha

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (Darwin)

iD8DBQFNqzaQpYOq9ODq/IoRAnZgAKCe8YPhgKYh7do0faMIPi8+24bWMQCdEYNh
GcPi/1e/cieih4xLoMRQCUg=
=jQ9P
-----END PGP SIGNATURE-----
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to