On Fri, May 6, 2011 at 11:40 AM, Hanno Schlichting <ha...@hannosch.eu>wrote:

> Are you using zope.sendmail's mail:queuedDelivery in the project? If
> yes, upgrade to zope.sendmail 3.5.3, which will make it into Zope
> 2.12.18. Earlier versions registered an atexit handler that wasn't
> compatible with Python 2.5+. The bug was only fixed in later versions
> of zope.sendmail but not backported to the 3.5 stable branch.

I accidentally sent my previous reply to Hanno directly. But I have since
bumped the zope.sendmail version in my versions.cfg file and ran buildout
again. I can confirm that the problem was zope.sendmail.

Thanks for the very prompt reply. You saved me a lot of debugging time.

Izak Burger
Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to