On Thu, Aug 25, 2011 at 2:50 AM, Wolfgang Schnerring <w...@gocept.com> wrote:
> So I'd like to propose to do the split the other way around: Not
> extract the core into something else and leave only a hollowed-out
> shell of integration and miscellany stuff behind, but rather tighten
> zope.component to its core and move the optional integration bits out
> of it, into separate packages.
> What do people think?
I would agree if we were starting over. But the damage is done
and stripping zope.component to its core would be backwards
This is, OTOH, an opportunity to maybe come up with a more appealing
name. While I like the term "component", my sense is that it probably
feels too heavy to a lot of Python programmers. "Registry" is at least
as bad and doesn't reflect the real use case.
Maybe something like "zope.plugins" would be better. When I try
to explain zope.component to people, I often explain it as a good
generic plugin mechanism.
Zope-Dev maillist - Zope-Dev@zope.org
** No cross posts or HTML encoding! **
(Related lists -