On Mon, 2011-09-26 at 21:47 -0400, Chris McDonough wrote:
> In case anyone is interested, I've made a stab at porting
> zope.sqlalchemy to Python 3 at
> http://svn.zope.org/zope.sqlalchemy/branches/chrism-py3/ .  Several
> tests still fail.  I could use some help fixing them.
> To run the test suite:
> - Create a Python 3.2 virtualenv.
> - Install nose into the virtualenv.
> - Check out the "chrism-py3" transaction branch from
>   svn://svn.zope.org/repos/main/transaction/branches/chrism-py3
> - Install the "chrism-py3" transaction checkout into the virtualenv,
>   e.g. $env32/bin/python setup.py develop.
> - Install this package into the virtualenv eg. run $env32/bin/python
>   setup develop.
> - Run $env32/bin/python setup.py nosetests.
> Currently 2 tests fail:

Mike Merickel solved this...

This is because the setuptools (and nose) testrunners do not respect the
``test_suite`` stanza at the bottom of ``tests.py``; these shouldn't be
getting run unless the DSN has postgres in it, and they are getting run
regardless (under sqlite).

That brings up how to cope with running test suites that depend on
zope.testrunner features in a cross-platform way.  Currently the
bootstrap script in this package wont run under Py3.

- C

Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to