On Thu, Mar 15, 2012 at 1:22 PM, Tres Seaver <tsea...@palladion.com> wrote:
> On 03/14/2012 09:00 PM, Zope tests summarizer wrote:
>> [1]    FAILED  winbot / ztk_dev py_265_win32
>> https://mail.zope.org/pipermail/zope-tests/2012-March/059300.html
>>
>> [2]    FAILED  winbot / ztk_dev py_265_win64
>> https://mail.zope.org/pipermail/zope-tests/2012-March/059301.html
>>
>> [3]    FAILED  winbot / ztk_dev py_270_win32
>> https://mail.zope.org/pipermail/zope-tests/2012-March/059302.html
>>
>> [4]    FAILED  winbot / ztk_dev py_270_win64
>> https://mail.zope.org/pipermail/zope-tests/2012-March/059303.html
>
> All fail with::
>
>  While:
>   Installing test-zopeapp.
>   Getting distribution for 'ZODB3>=3.10'.
>  Error: Picked: zodb3 = 3.10.5
>
> Ideas?

I think I fixed that in zope.app.publication now. Note that these are
dev builds, so they use all packages from SVN.

z.a.publication added a new requirement for ZODB3>=3.10. But ZODB on
its 3.10 branch notes its version as 3.10dev. As 3.10dev < 3.10 the
check failed.

Relaxing the check to "ZODB3>=3.10dev" should fix this. Alternatively
"ZODB3>3.10.999" would have worked as well.

Hanno
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists -
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to