2012/4/17 Tres Seaver <tsea...@palladion.com>:
> Hash: SHA1
> On 03/15/2012 05:21 AM, Marius Gedminas wrote:

I have made this change, not Marius.

>> Log message for revision 124600: Revert a move of `README.txt` to
>> unbreak ``zope.app.apidoc``.
>> Changed: _U  zope.deprecation/trunk/ U
>> zope.deprecation/trunk/CHANGES.txt U zope.deprecation/trunk/README.txt
>> U   zope.deprecation/trunk/setup.py A
>> zope.deprecation/trunk/src/zope/deprecation/README.txt
> I'd like to argue against this reversion:  the ZTK 1.0 / 1.1 checkouts
> should all be using the stable 3.4 branch.  If the z.a.apidoc trunk needs
> fixing (why in hell does it depend on the existince of a README.txt at
> package scope in another package?) let's fix it there.

What if I use ZTK 1.1 but still want zope.app.apidoc (that was removed
from the set)?

The README.txt in project root is not included in the egg. So I would
have to remove 'Zope Deprecation' chapter from the apidoc Book and
make a new major release of this deprecated module.

Instead, I restored the location of README.txt, a move that does not
have any benefit, so that an app that includes zope.app.apidoc would
start, and I do not need to remove any content. Chose lesser evil to
fix breakage.

Gediminas Paulauskas
Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists -
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to