Hi All,

While trying to debug another problem, I re-ran some Jenkins jobs for two of my packages, which promptly failed under Python 2.5:


Now, the issue here is that zope.interface 4.0 and above no longer supports Python 2.5:


That's fine, but I'd like the above projects to continue 2.5 support for the time being.

The simple solution would be to add a versions section to the buildout here:


...and pin the versions in the tox.ini here:


...however, that doesn't give the correct result. The version requirement is "use the latest version of all packages that work with the Python version under test" and the changes I've suggested would mean that on Python 2.6 and 2.7, the latest version of zope.interface wouldn't be used.

What makes this even more "interesting" is that zope.interface isn't a direct requirement of either of these projects, it's a dependency of a dependency in both cases.

How have other people solved this?


Simplistix - Content Management, Batch Processing & Python Consulting
           - http://www.simplistix.co.uk

Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists -
https://mail.zope.org/mailman/listinfo/zope )

Reply via email to