zope.component 4.0.0 and zope.browserpage 3.12.2 are not compatible.

Tres, I think you made browserpage compatible on trunk, can you create
a new release?
Or anybody can add me as a package maintainer on pypi, I am do3cc.

On Wed, Jul 4, 2012 at 11:05 AM, Patrick Gerken <do3cc...@googlemail.com> wrote:
> On Wed, Jul 4, 2012 at 3:00 AM, Zope tests summarizer <nore...@zope.org> 
> wrote:
>> This is the summary for test reports received on the
>> zope-tests list between 2012-07-02 00:00:00 UTC and 2012-07-03 00:00:00 UTC:
>>
>> See the footnotes for test reports of unsuccessful builds.
>>
>> An up-to date view of the builders is also available in our
>> buildbot documentation:
>> http://docs.zope.org/zopetoolkit/process/buildbots.html#the-nightly-builds
>>
>> Reports received
>> ----------------
>>
>>        Zope 3.4 Known Good Set / py2.4-32bit-linux
>>        Zope 3.4 Known Good Set / py2.4-64bit-linux
>>        Zope 3.4 Known Good Set / py2.5-32bit-linux
>>        Zope 3.4 Known Good Set / py2.5-64bit-linux
>>        Zope-2.10 Python-2.4.6 : Linux
>>        Zope-2.11 Python-2.4.6 : Linux
>>        Zope-2.12 Python-2.6.8 : Linux
>>        Zope-2.13 Python-2.6.8 : Linux
>>        Zope-2.13 Python-2.7.3 : Linux
>>        Zope-trunk Python-2.6.8 : Linux
>>        Zope-trunk Python-2.7.3 : Linux
>>        winbot / ZODB_dev py_265_win32
>>        winbot / ZODB_dev py_265_win64
>>        winbot / ZODB_dev py_270_win32
>>        winbot / ZODB_dev py_270_win64
>> [1]    winbot / zope.app.applicationcontrol_py_265_32
>> [2]    winbot / zope.app.authentication_py_265_32
>> [3]    winbot / zope.app.component_py_265_32
>> [4]    winbot / zope.app.container_py_265_32
>> [5]    winbot / zope.app.exception_py_265_32
>> [6]    winbot / zope.app.generations_py_265_32
>> [7]    winbot / zope.app.publisher_py_265_32
>> [8]    winbot / zope.app.rotterdam_py_265_32
>> [9]    winbot / zope.app.session_py_265_32
>> [10]   winbot / zope.app.testing_py_265_32
>> [11]   winbot / zope.app.zcmlfiles_py_265_32
>>        winbot / ztk_10 py_254_win32
>>        winbot / ztk_10 py_265_win32
>>        winbot / ztk_10 py_265_win64
>>        winbot / ztk_11 py_254_win32
>>        winbot / ztk_11 py_265_win32
>>        winbot / ztk_11 py_265_win64
>>        winbot / ztk_11 py_270_win32
>>        winbot / ztk_11 py_270_win64
>>
>> Non-OK results
>> --------------
>>
>> [1]    FAILED  winbot / zope.app.applicationcontrol_py_265_32
>>        https://mail.zope.org/pipermail/zope-tests/2012-July/064994.html
>>
>>
>> [2]    FAILED  winbot / zope.app.authentication_py_265_32
>>        https://mail.zope.org/pipermail/zope-tests/2012-July/065004.html
>>
>>
>> [3]    FAILED  winbot / zope.app.component_py_265_32
>>        https://mail.zope.org/pipermail/zope-tests/2012-July/064997.html
>>
>>
>> [4]    FAILED  winbot / zope.app.container_py_265_32
>>        https://mail.zope.org/pipermail/zope-tests/2012-July/064996.html
>>
>>
>> [5]    FAILED  winbot / zope.app.exception_py_265_32
>>        https://mail.zope.org/pipermail/zope-tests/2012-July/065000.html
>>
>>
>> [6]    FAILED  winbot / zope.app.generations_py_265_32
>>        https://mail.zope.org/pipermail/zope-tests/2012-July/064992.html
>>
>>
>> [7]    FAILED  winbot / zope.app.publisher_py_265_32
>>        https://mail.zope.org/pipermail/zope-tests/2012-July/065002.html
>>
>>
>> [8]    FAILED  winbot / zope.app.rotterdam_py_265_32
>>        https://mail.zope.org/pipermail/zope-tests/2012-July/064995.html
>>
>>
>> [9]    FAILED  winbot / zope.app.session_py_265_32
>>        https://mail.zope.org/pipermail/zope-tests/2012-July/065003.html
>>
>>
>> [10]   FAILED  winbot / zope.app.testing_py_265_32
>>        https://mail.zope.org/pipermail/zope-tests/2012-July/064998.html
>>
>>
>> [11]   FAILED  winbot / zope.app.zcmlfiles_py_265_32
>>        https://mail.zope.org/pipermail/zope-tests/2012-July/064999.html
>
> I didn't check ALL of the failures but the ones I checked all
> complayed that the layer attribute of browser:page is unknown.
> Apparently I still don't understand zcml enough, because I didn't find
> out, which package really provides this.
> There were some changes in zope.browserpage related to layers, but
> they aren't released as eggs yet and the test uses the eggified
> version of browser.page zope.publisher got a new release before the
> first failure, But I don't understand how this could affect the
> failure.
> Maybe somebody else here has an idea?
>>
>>
>> _______________________________________________
>> Zope-Dev maillist  -  Zope-Dev@zope.org
>> https://mail.zope.org/mailman/listinfo/zope-dev
>> **  No cross posts or HTML encoding!  **
>> (Related lists -
>>  https://mail.zope.org/mailman/listinfo/zope-announce
>>  https://mail.zope.org/mailman/listinfo/zope )
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists -
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to