On Fri, Feb 08, 2013 at 01:00:02AM +0000, Zope tests summarizer wrote:
> Non-OK results
> --------------
> 
> [1]    FAILED  Still Failing - zopetoolkit_trunk - Build # 164
>        https://mail.zope.org/pipermail/zope-tests/2013-February/071972.html
> 
> 
> [2]    FAILED  Still Failing - zopetoolkit_trunk_app - Build # 147
>        https://mail.zope.org/pipermail/zope-tests/2013-February/071973.html

(24-hour lag, both next builds are fine.)

> [4]    FAILED  winbot / zope.tal_py_265_32
>        https://mail.zope.org/pipermail/zope-tests/2013-February/071996.html

This one's interesting.  At a first guess, one of my changes for Python
3 compatibility (making sure the open file passed to xml.parser.expat is
open in binary mode -- expat insists on byte strings) now causes
line-endings troubles on Windows.

> [5]    FAILED  winbot / zope.testrunner_py_265_32
>        https://mail.zope.org/pipermail/zope-tests/2013-February/071997.html

Even more interesting.  The code, as written, should not work on Python
2.6, so the failure makes sense.  But why can't I reproduce it locally,
with detox -e py26?

Answer: because the setup.py test exits with status code zero.  Ouch.
Fixing...

Marius Gedminas
-- 
If you sat a monkey down in front of a keyboard, the first thing typed would be
a unix command.
                -- Bill Lye

Attachment: signature.asc
Description: Digital signature

_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists -
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to