On Fri, Mar 15, 2013 at 01:00:01AM +0000, Zope tests summarizer wrote:
> [1]    Still Failing - zopetoolkit_trunk - Build # 202

Back to regular failures:
- test-ztk-zope.traversing
- test-ztk-zope.dublincore
- test-ztk-zope.container
- test-ztk-zope.catalog

ImportError: No module named persistent
ImportError: No module named persistent.dict
AttributeError: 'module' object (BTrees) has no attribute 'Interfaces'
ImportError: No module named persistent.cPersistence
ImportError: cannot import name 
(zope.container._zope_container_contained.)ContainedProxyBase

These sound familiar.

> [2]    winbot / z3c.form_py_265_32
> [3]    winbot / z3c.form_py_265_32
> [4]    winbot / z3c.formui_py_265_32
> [5]    winbot / z3c.layer.ready2go_py_265_32
> [6]    winbot / z3c.pagelet_py_265_32

lxml

> [7]    winbot / zope.app.localpermission_py_265_32

https://github.com/zopefoundation/zope.app.localpermission does not have
a buildout.cfg

Lossy git conversion?  A buildout.cfg existed in
http://zope3.pov.lt/trac/browser/zope.app.localpermission/trunk?rev=126937

It was created by an svn mv from zope.localpermission in r98059:
http://zope3.pov.lt/trac/log/zope.app.localpermission/trunk/buildout.cfg?rev=126937

> [8]    winbot / zope.app.wsgi_py_265_32

I misunderstood last time.  "*** empty log message ***" does not mean
this is a clone of an empty repo.  It's *the actual svn commit message*
of the last commit: http://zope3.pov.lt/trac/changeset/124092

The actual problem is

    c:\Python26_32\python.exe bootstrap.py
    Downloading 
http://pypi.python.org/packages/2.6/s/setuptools/setuptools-0.6c11-py2.6.egg
    Traceback (most recent call last):
      File "bootstrap.py", line 257, in <module>
        import zc.buildout.buildout
      File 
"c:\temp\tmpjpk_wq\zc.buildout-2.0.1-py2.6.egg\zc\buildout\buildout.py", line 
18, in <module>
        import zc.buildout.easy_install
      File 
"c:\temp\tmpjpk_wq\zc.buildout-2.0.1-py2.6.egg\zc\buildout\easy_install.py", 
line 61, in <module>
        pkg_resources.Requirement.parse('distribute')
    AttributeError: 'NoneType' object has no attribute 'location'

Weird.

> [9]    winbot / zope.site_py_265_32

buildout fails with

  We already have: zope.security 3.9.0
  but zope.site 4.0.0a2.dev0 requires 'zope.security>=4.0.0a3'.

> [10]   winbot / zope.viewlet_py_265_32

buildout fails with

  We already have: zope.security 3.9.0
  but zope.publisher 4.0.0a2 requires 'zope.security>=4.0.0a1'.

Marius Gedminas
-- 
http://pov.lt/ -- Zope 3/BlueBream consulting and development

Attachment: signature.asc
Description: Digital signature

_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists -
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to