Hi,

I'm having a strange error when trying to install PlonePAS in a newly created plone site. Working with versions: PluggableAuthService-1.1b2, PlonePAS 0.4.0, plone2.1-rc3, zope2.8.1-final and python 2.4.1.


I'm getting the traceback:

Traceback (innermost last):
Module Products.CMFQuickInstallerTool.QuickInstallerTool, line 311, in installProduct
- __traceback_info__: ('PlonePAS',)
Module Products.ExternalMethod.ExternalMethod, line 225, in __call__
- __traceback_info__: ((<PloneSite at /etx>,), {}, None)
Module /opt/eurotux/rsa/zope28/run/produtos/eurotuxintranet/PlonePAS/Extensions/Install.py, line 796, in install Module /opt/eurotux/rsa/zope28/run/produtos/eurotuxintranet/PlonePAS/Extensions/Install.py, line 337, in restoreGroupData
Module Products.PlonePAS.tools.groups, line 67, in addGroup
Module Products.PlonePAS.tools.groupdata, line 134, in setGroupProperties
RuntimeError: Mutable property provider shadowed by read only provider


Printing the propertysheet id, I get 'mutable-properties'.

It looks like it is considering that the property sheet is not implementing IMutablePropertySheet. In 'groupdata.setGroupProperties' (line 130), the following statement is returning false:
   ...
   if IMutablePropertySheet.isImplementedBy(sheet):
       sheet.setProperty(group, k, v)
       modified = True
   ...

I commented the if statement, and it worked.
   ...
   #if IMutablePropertySheet.isImplementedBy(sheet):
   sheet.setProperty(group, k, v)
   modified = True
   ...

Why is 'isImplementedBy' returning False?
Is this a known issue? Or should be a problem of my zope-2.8.1 installation?


Tanks,

Ricardo Alves

_______________________________________________
Zope-PAS mailing list
Zope-PAS@zope.org
http://mail.zope.org/mailman/listinfo/zope-pas

Reply via email to