Recently upgraded from PAS 1.4 to 1.5.3 (and Zope 2.8.8 to 2.11.2).  
I'm having a new problem with basic auth; namely, that basic auth  
information is ignored when using wget. Browsers work fine, ZMI asks  
for basic auth creds. wget (and lynx, for that matter) doesn't.

For example, I'm doing:

wget --user myuser --password mypassword http://localhost:8080/path/to/thing

I threw a breakpoint in ZPublisher/ to see what auth  
information was in the request environment; there is none. I also  
tried wget http://user:p...@localhost:8080/, just for kicks, but of  
course the same problem.

A key datapoint: it works when I pass the --no-auth-challenge option  
to wget.

For all intents and purposes, this is a vanilla install of PAS and  
Zope. The plugins that are active appear identical to a Zope 2.8.8/PAS  
1.4 instance that /does/ work. Any ideas?

Zope-PAS mailing list

Reply via email to