On Fri, 11 Nov 2005 15:31:22 -0200 (EDT)
"leonardo santos" <[EMAIL PROTECTED]> wrote:

> Fernando, já fiz isso, já mudei no  portal_properties ...
> já tentei um monte de coisa...
> 
> colocando o meta .. os templates ficam certos, mais os conteudos e o menu 
> ficam
> desconfigurado.. ta complicado.. Rsss
> 
> Qualquer ajuda é bem vinda!!!


Ao que tudo indica vc está com conteúdo misto sendo renderizado.

 Se:
 (conteúdo em iso-8859-1) + (conteúdo em UTF-8) 
 ===(tag encoding UTF-8)==> bixa ISO e mostra UTF-8 ok

 Se:
 (conteúdo em iso-8859-1) + (conteúdo em UTF-8) 
 ===(tag encoding iso-8859-1)==> bixa UTF-8 e mostra iso-8859-1 ok

Assim, basta decidir qual será o encoding final da vizualização
que vc vai querer, configurá-lo, e sair re-editando tudo que estiver
aparecendo bixado (pois terá sido criado com a *outra* codificação).

Outra coisa, se vc editar o conteúdo manualmente para corrigi-lo,
tenha certeza de que a ferramenta que vc está usando esteja utilizando
o encoding que vc *esperava*. Por exemplo, se estiver criando conteúdo
via Firefox, verifique se ele está usando utf-8 ou ido-8859-1 ou seja lá o
que for. Isso está configurado Edit/preferences/General/Languages/
em Default Character Encoding.

É preciso estar muito atento, senão ao invés de corrigir vai se aumentar
o problema. Se estiver usando um editor de texto, certifique-se de que
encoding ele está gravando os arquivos.

Infelizmente não tem nenhum jeito fácil (que eu conheça) de corrigir
encodings misturados em um portal. É atenção e mão na massa.

Abração
Senra



Para enviar uma mensagem: zope-pt@yahoogrupos.com.br
Para desistir envie uma mensagem em branco para: [EMAIL PROTECTED] 
Links do Yahoo! Grupos

<*> Para visitar o site do seu grupo na web, acesse:
    http://br.groups.yahoo.com/group/zope-pt/

<*> Para sair deste grupo, envie um e-mail para:
    [EMAIL PROTECTED]

<*> O uso que você faz do Yahoo! Grupos está sujeito aos:
    http://br.yahoo.com/info/utos.html

 


Responder a