Rodrigo Dias Arruda Senra wrote:
> [ "trader_df" <[EMAIL PROTECTED]> ]:
> |  Olá pessoal, me foi pedido aqui no trabalho que fizesse a migração
> | do portal da empresa, que atualmente está rodando na versão 2.8.1 do
> | Zope e na versão 2.1.0 do Plone, para as versões 2.9.1 e 2.1.2 do
> | Zope e do Plone, respectivamente. Gostaria que alguém me desse uma
> | luz da forma mais ótima de se fazer isso. Tentei transferir o
> | Data.fs, mas o site carregou todo desformatado ... Qlqr dica já ajuda
> | d+ ... 
> 
>  A boa notícia é que *é* possível pois eu fiz.
>  A má notícia é que não é tão simples quanto copiar um Data.fs de um
>  lado para o outro.

+1

Do Plone 2.1 para o 2.1.2 foram alterados bastante estilos CSS. Se você 
fez uma customização razoável do layout, provavelmente você vai ter que 
dar uma repassada no CSS e quem sabe até nos templates.

>  Minha sugestão é exportar o site (.zexp) no site antigo. Importar
>  o .zexp no site novo. Usar a ferramenta portal_migration, e se depois
>  disso ainda continuar com trechos quebrados( é provável), 
>  comece examinando o que foi alterado em portal_skins/custom, tem boas
>  chances do vilão estar lá.

Eu começaria por algo levemente diferente. Remonte a estrutura do portal 
antigo em produção (uma nova instância e uns links simbólicos resolvem) 
e faça um bkp do Data.fs, troque a versão do Plone e os produtos que o 
acompanham (reaponte os links) e tente rodar a migração.

Vai quebrar o layout dos tipos ATContentTypes mas no próximo restart 
estará tudo certo, aí você poderá iniciar o trabalho de conferência de 
CSS e templates.

Você realmente precisa de Zope 2.9? Se não, melhor não alterar a versão, 
no máximo fazer um upgrade para o Zope 2.8.6 (aconselhável). O ambiente 
recomendado hoje para rodar o Plone 2.1.2 é Python 2.3.5 e Zope 2.7 ou 2.8.

Se por algum motivo (provavelmente Zope3) você realmente precisar do 
Zope 2.9, faça primeiro todas as migrações do Plone e só depois que 
estiver tudo certo migre o Zope. Mas entenda que se mudar de idéia a 
migração para trás, Zope 2.9 -> Zope 2.8 pode te trazer problemas.

Abraço,

-- 
Jean Ferri

                
_______________________________________________________ 
Novo Yahoo! Messenger com voz: Instale agora e faça ligações de graça. 
http://br.messenger.yahoo.com/


Para enviar uma mensagem: zope-pt@yahoogrupos.com.br
Para desistir envie uma mensagem em branco para: [EMAIL PROTECTED] 
Links do Yahoo! Grupos

<*> Para visitar o site do seu grupo na web, acesse:
    http://br.groups.yahoo.com/group/zope-pt/

<*> Para sair deste grupo, envie um e-mail para:
    [EMAIL PROTECTED]

<*> O uso que você faz do Yahoo! Grupos está sujeito aos:
    http://br.yahoo.com/info/utos.html

 



Responder a