Estou tentando usar o ZOPE 2.9.0, python 2.4.2 e o plone 2.5 alpha 2, mas esta dando um erro. Vejam:

/usr/local/Zope-2.9.0/lib/python/App/ImageFile.py:21: DeprecationWarning: Using OFS.content_types is deprecated (will be removed in Zope 2.11). Instead use zope.app.contenttypes.
  from OFS.content_types import guess_content_type
/usr/local/Zope-2.9.0/bin/zopeinstance/Products/Five/i18n.py:22: DeprecationWarning: MessageID: Mutable i18n messages ("message ids") have been deprecated in favour of immutable ones and will be removed in Zope 3.3.  Please use zope.i18nmessageid.Message instead.
  from zope.i18nmessageid import MessageID
Traceback (most recent call last):
  File "/usr/local/Zope-2.9.0/lib/python/Zope2/Startup/run.py", line 56, in ?
    run()
  File "/usr/local/Zope-2.9.0/lib/python/Zope2/Startup/run.py", line 21, in run
    starter.prepare()
  File "/usr/local/Zope-2.9.0/lib/python/Zope2/Startup/__init__.py", line 98, in prepare
    self.startZope()
  File "/usr/local/Zope-2.9.0/lib/python/Zope2/Startup/__init__.py", line 257, in startZope
    Zope2.startup()
  File "/usr/local/Zope-2.9.0/lib/python/Zope2/__init__.py", line 46, in startup    from Zope2.App.startup import startup as _startup
  File "/usr/local/Zope-2.9.0/lib/python/Zope2/App/startup.py", line 33, in ?
    import OFS.Application
  File "/usr/local/Zope-2.9.0/lib/python/OFS/Application.py", line 27, in ?
    from App.ApplicationManager import ApplicationManager
  File "/usr/local/Zope-2.9.0/lib/python/App/ApplicationManager.py", line 32, in ?
    from Products.PageTemplates.PageTemplateFile import PageTemplateFile
  File "/usr/local/Zope-2.9.0/lib/python/Products/PageTemplates/PageTemplateFile.py", line 27, in ?
    from PageTemplate import PageTemplate
  File "/usr/local/Zope-2.9.0/lib/python/Products/PageTemplates/PageTemplate.py", line 27, in ?
    from Expressions import getEngine
  File "/usr/local/Zope-2.9.0/lib/python/Products/PageTemplates/Expressions.py", line 23, in ?
    from TALES import Engine
  File "/usr/local/Zope-2.9.0/lib/python/Products/PageTemplates/TALES.py", line 24, in ?
    from GlobalTranslationService import getGlobalTranslationService
  File "/usr/local/Zope-2.9.0/lib/python/Products/PageTemplates/GlobalTranslationService.py", line 20, in ?
    import Products.Five.i18n
  File "/usr/local/Zope-2.9.0/bin/zopeinstance/Products/Five/__init__.py", line 25, in ?
    monkey.monkeyPatch()
  File "/usr/local/Zope-2.9.0/bin/zopeinstance/Products/Five/monkey.py", line 26, in monkeyPatch
    from Products.Five import interfaces, i18n
  File "/usr/local/Zope-2.9.0/bin/zopeinstance/Products/Five/i18n.py", line 26, in ?
    from Products.PageTemplates import GlobalTranslationService as GTS
ImportError: cannot import name GlobalTranslationService

O que pode ser este erro sobre GlobalTranslationService. O pacote que veio junto com o plone 2.5 alpha 2 estava com uma versão do plonetranslations antiga e atualizei para a versão 2.5-B, mas mesmo assim dá erro.

Agradeço desde já.

--
Fernando de Barros Sanches Arce
Tecnólogo em Desenvolvimento de Sistemas Web


Para enviar uma mensagem: zope-pt@yahoogrupos.com.br
Para desistir envie uma mensagem em branco para: [EMAIL PROTECTED]




Links do Yahoo! Grupos

Responder a