Yellow,

Parece-me a mim que tens o Zope configurado pra usar UTF-8 e quando
usas acentos numa variavel assim precisas de configurar o Zope para
usar ISO-8859-1.
Edita o zope.conf e configura a variavel "default-zpublisher-encoding"
para iso-8859-1
Depois restart e testa.

C U
Hugo



On 4/13/06, Diego Manenti Martins <[EMAIL PROTECTED]> wrote:
> pelo o que andei lendo, o zope que não suporta caracteres unicode..
> alguma sugestão?
>
> On 4/13/06, Diego Manenti Martins <[EMAIL PROTECTED]> wrote:
> > Opa,
> > tenho um script python:
> >
> > val = u'téste'
> > context.set_param_zsql(param='address', value=val, name='area_peca')
> > return ""
> >
> > e um Z SQL Method vom os argumentos param value name:
> >
> > update tabela set <dtml-var param>='<dtml-var value>'
> > where(name='<dtml-var name>')
> >
> > quandou testo o script ele retorna um erro:
> >
> > Tipo de Erro
> >     UnicodeEncodeError
> > Valor do Erro
> >     'ascii' codec can't encode character u'\xe9' in position 31:
> > ordinal not in range(128)
> >
> > alguem sabe o que está acontecendo e como resolver?
> >
>
>
> Para enviar uma mensagem: zope-pt@yahoogrupos.com.br
> Para desistir envie uma mensagem em branco para: [EMAIL PROTECTED]
> Links do Yahoo! Grupos
>
>
>
>
>
>
>
>


--
Hugo Ramos - [EMAIL PROTECTED]
http://www.orkut.com/Profile.aspx?uid=10082105466310142690
http://otuggapoesia.blogspot.com/
http://otugga.blogspot.com/


Para enviar uma mensagem: zope-pt@yahoogrupos.com.br
Para desistir envie uma mensagem em branco para: [EMAIL PROTECTED] 
Links do Yahoo! Grupos

<*> Para visitar o site do seu grupo na web, acesse:
    http://br.groups.yahoo.com/group/zope-pt/

<*> Para sair deste grupo, envie um e-mail para:
    [EMAIL PROTECTED]

<*> O uso que você faz do Yahoo! Grupos está sujeito aos:
    http://br.yahoo.com/info/utos.html

 


Responder a