Mais alguma idéia?
Alguém já viu isto funcionando no Plone?

para facilitar a leitura trunquei o código e o erro do post e coloquei
o código em [1] e o trace do erro em [2]

[1] http://paste.plone.org/6107
[2] http://paste.plone.org/6105

[]s
daniel

--- Em zope-pt@yahoogrupos.com.br, "Daniel Vainsencher"
<[EMAIL PROTECTED]> escreveu
>
> --- Em zope-pt@yahoogrupos.com.br, Fabiano Marcon <[EMAIL PROTECTED]>
escreveu
> >
> > Opa Daniel,
> > 
> > Eu já tive um problema parecido, cada vez que gerava o código e
tentava 
> > reiniciar a instância zope dava um AttributeError em uma "stringona" 
> 
> Oi Fabiano.
> 
> Acho que não se trata de um problema no código gerado no AGX.
> 
> No meu caso a instância reinicia sem erros. O erro ocorre quando 
> tento fazer a associação entre os objetos. Fiz o teste apenas com 
> duas classes simples e uma classe de associação sem atributos e 
> sem workflow e o erro permanece.
> 
> Parece que o Archetypes não consegue criar ou encontrar a classe
> associativa.
> 
> Alguma idéia?
> 
> > maluca. No meu caso era uma transição do workflow que eu tinha
> esquecido 
> > de colocar o nome, aí como nome gerava essa stringona e dava erro.
> > 
> > Fabiano Marcon
> > 
> > Daniel Vainsencher Maya Monteiro escreveu:
> > > Olá,
> > >
> > > Estou com problemas para usar classes associativas no Plone.
> > > Ao tentar associar objetos ocorre um erro(trace abaixo) e a
> associação 
> > > não
> > > é efetivada.
> > >
> > > Utilizei o Poseidon 4.1 para modelar as classes:
> > > - Questao
> > > - Prova
> > > - ConfiguracaoDeQuestao (classe associativa entre Prova e Questao)
> > >
> > > Utilizei o AGX 1.5.0 do svn
> > >
> > > Como o procedimento é descrito no ArchGenXML Getting Started[1]
> > > imaginei que houvesse algum problema na versão de Plone que estava 
> > > usando.
> > > Testei então nas versões:
> > >
> > > Zope2.8.4 + Plone2.1.2
> > > Zope2.8.4 + Plone2.1.3
> > > Zope2.9.3 + Plone2.5
> > >
> > > e o erro persistiu em todas.
> > >
> > > O schema da classe Prova parece coerente:
> > >
> > > Alguém tem idéia do que seja?
> > >
> > > [1] -
http://plone.org/documentation/tutorial/archgenxml-getting-started/relationships
> > >
> > > []s
> > > Daniel Vainsencher







Para enviar uma mensagem: zope-pt@yahoogrupos.com.br
Para desistir envie uma mensagem em branco para: [EMAIL PROTECTED] 
Links do Yahoo! Grupos

<*> Para visitar o site do seu grupo na web, acesse:
    http://br.groups.yahoo.com/group/zope-pt/

<*> Para sair deste grupo, envie um e-mail para:
    [EMAIL PROTECTED]

<*> O uso que você faz do Yahoo! Grupos está sujeito aos:
    http://br.yahoo.com/info/utos.html

 



Responder a