Agora só falta o do UTF-8... ;-)

http://www.zope.org/Members/adustman/Tips/no_limits

- Roberto

On 12/20/06, Roberto Alcantara <[EMAIL PROTECTED]> wrote:

Bingo !  :-)
Muito obrigado Tânia, acertou em cheio!!!

Se alguém tiver uma dica certeira dessas p/ o problema do UTF8 ou LIMIT,
me avisem ;-)

abraços,
 - Roberto


On 12/20/06, Tania Andrea <[EMAIL PROTECTED]> wrote:
>
>   Roberto,
>
> Se entendi direito a solução para o trecho abaixo:
>
> "
> Mas o que realmente eu quebrei a cabeça tentando fazer e não saiu foi
> concatenar o id_post que eu recebo lá na consulta com uma string no link:
>
> <div tal:repeat="records context/show_ forum">
>                     <a href="http://www.eletroni ca.org/modules.
> php?name= Forums&id=???
> <http://www.eletronica.org/modules.php?name=Forums&id=???>">
>                     <span tal:replace="records/topic_
> title">Topic_Title</span>   </a>
> </div>
> "
>
> Seria isso:
>
> <div tal:repeat="records context/show_ forum">
>                     <a href="" tal:attributes="href
> string:http://www.eletroni ca.org/modules. php?name= Forums&id=${
> <http://www.eletronica.org/modules.php?name=Forums&id=???>id_post}">
>                     <span tal:replace="records/topic_
> title">Topic_Title</span>   </a>
> </div>
>
> Sendo que o id_post foi pego do request ou definido no próprio template,
> etc.
>
> Até!
> Tânia Andrea
>
>
> ----- Mensagem original ----
> De: Roberto Alcantara <[EMAIL PROTECTED]>
> Para: zope-pt@yahoogrupos.com.br
> Enviadas: Terça-feira, 19 de Dezembro de 2006 21:33:19
> Assunto: [zope-pt] Concatenar string dentro do portlet
>
>  Pessoal, já tentei de tudo aqui e não deu certo... apelando pra vocês
> novamente ;-)
> Tenho um fórum que roda em um servidor MySQL. Fiz um query que retorna
> os títulos e ids dos últimos tópicos.
>
> O primeiro problema problema é que no Z SQL Method não aceitar colocar
> "LIMIT X" no final. Dá erro no SQL.  Também não consigo selecionar o charset
> do mysql (SET NAMES utf8). Dá erro também.
>
> Mas o que realmente eu quebrei a cabeça tentando fazer e não saiu foi
> concatenar o id_post que eu recebo lá na consulta com uma string no link:
>
> <div tal:repeat="records context/show_ forum">
>                     <a href="http://www.eletroni ca.org/modules.
> php?name= Forums&id=???
> <http://www.eletronica.org/modules.php?name=Forums&id=???>">
>                     <span tal:replace="records/topic_
> title">Topic_Title</span>   </a>
> </div>
>
> Onde estão as ??? é onde eu preci por o id_post. Mas como fazer isso, se
> eu não posso colocar o span (que quebra a sintaxe) ?
>
> Desde já, valeu ;-)
>
>  - Roberto
>
>
>
>
> --
>
> - Roberto
>
>
> __________________________________________________
> Fale com seus amigos de graça com o novo Yahoo! Messenger
> http://br.messenger.yahoo.com/
>
> >



--

- Roberto




--

- Roberto

Responder a