Nope, mas um dia eu libero...

On 1/25/07, Rodrigo Castardo <[EMAIL PROTECTED]> wrote:


  Fala Xiru!

Esse seu plugin tah em algum repositorio?

[]'s

On 1/25/07, xiru <[EMAIL PROTECTED] > wrote:

>   Recentemente detectei numa instalação de um cliente que o
> LDAPUserFolder não faz um cache eficiente da implementação da
> interface authenticateCredentials e gera um tráfego considerável de
> conexoes LDAP (o que torna um site, sobre alta carga, muito.... muito
> lento).
>
> Eu escrevi um plugin para o PlonePAS que faz a autenticação e garante
> o cache e ficou bem mais rápido (e não precisamos mais do
> LDAPUserFolder e do LDAPMultiPlugins).
>
> Se você tem muitos usuarios no LDAP, seria uma das coisas que eu
> investigaria...
>
>
> On 1/25/07, Ivo Couto <[EMAIL PROTECTED] <icbrandao%40yahoo.com.br>>
> wrote:
> >
> >
> >
> >
> >
> >
> >
> > valeu a dica!
> >
> > Ivo Couto Brandão
> > [EMAIL PROTECTED] <icbrandao%40yahoo.com.br>
> >
> >
> >
> > ----- Mensagem original ----
> > De: Rodrigo Senra <[EMAIL PROTECTED] <rodsenra%40gpr.com.br>>
> > Para: zope-pt@yahoogrupos.com.br <zope-pt%40yahoogrupos.com.br>
> > Enviadas: Quinta-feira, 25 de Janeiro de 2007 10:12:31
> > Assunto: Re: [zope-pt] quantidade de usuários x desempenho
> >
> >
> >
> >
> >
> > [ Ivo Couto ]:
> >
> > |Administro um Portal com mais de 18 mil usuários e constantemente
> > |este portal está caindo ou ficando muito lento.
> > |A informação que obtive de algumas pessoas é que o problema é a
> grande
> > |quantidade de usuários no Portal. Essa informação procede?
> >
> > Pode ser. Vc vai precisar fazer um profiling para identificar melhor
> > a razão da queda e o gargalo. Está faltando CPU ? Está faltando
> > memória ? A autenticação é que demora ? A geraçcão de páginas
> > (renderização) é que demora ? O acesso a dados (banco relacional,
> ZODB)
> > é que demora ?
> >
> > Não existe resposta mágica, vc vai ter que fuçar para diagnosticar
> > o problema.
> >
> > | O zope não é capaz de gerenciar uma grande quantidade de usuários?
> >
> > Os usuários se "logam" no Plone ou apenas vizualizam páginas geradas
> > pelo Plone ? Se for o primeiro caso, o problema pode ser a dificuldade
> > de gerar uma cache com páginas pré-renderizadas. Sem isso, para cada
> > acesso de usuário autenticado será necessário rodar o engine de
> > geração de páginas dinâmicas e a infra-estrutura de check de segurança
> > e aí o bixo pode pegar para um número tão alto.
> >
> > Abração,
> > Senra
> >
> > ------------ -
> > Rodrigo Senra
> > GPr Sistemas
> > http://www.gpr. com.br
> >
> >
> > __________________________________________________
> > Fale com seus amigos de graça com o novo Yahoo! Messenger
> > http://br.messenger.yahoo.com/
> >
> >
>
> --
> Fabiano Weimar dos Santos (xiru)
> Weimar Consultoria
>
> Hospedagem Plone, Zope e Pyhon
> http://www.pytown.com
>
>


--
Castardo
ThreePointsWeb
[EMAIL PROTECTED]
+55 61 8166-4109




--
Fabiano Weimar dos Santos (xiru)
Weimar Consultoria

Hospedagem Plone, Zope e Pyhon
http://www.pytown.com

Responder a