Substitua:
<div tal:define="box_id string:modelo;
por
<div metal:define-macro="portlet" tal:define="box_id string:modelo;

On 5/25/07, Natalia Souza <[EMAIL PROTECTED]> wrote:

  Oi

Segue:

<div tal:define="box_id string:modelo;
portal_publicator nocall:here/portal_publicator;
pb
python:portal_publicator.getPublicationBoxesInfo(box_id);
isVisible pb/visible;"
tal:condition="python:template.getId()!='cinza' and isVisible">

<div tal:define="box_items python:pb['items']">
<tal:block tal:repeat="obj box_items">
<div tal:define="oddrow repeat/obj/odd;
item_id obj/Id;
global item_idRestrict obj/Id;
item_title obj/Title;
item_url obj/RelativeContentURL;
new_window obj/NewWindow;
item_icon obj/Icon;
item_modified obj/ModificationDate;
item_description obj/Description;
item_date obj/CreationDate;"
tal:condition="python:item_url">
<span tal:define="global dateFor obj/CreationDate" />
<a href=""
tal:attributes="href string:${portal_url}/${item_url};
target python:test
(new_window, '_blank', None);">
<span tal:content="python:test(item_title, item_title,
item_id)"
class="titleBox">Title</span>
<span tal:content="python:DateTime(dateFor).strftime('%d/%m/%
y -
') + DateTime(dateFor). TimeMinutes()[:2] + 'h' + DateTime(dateFor).
TimeMinutes()[3:5]" class="DateNews" style="color: #003366; font-
size:
10px;">Date create</span>
</a><br/>
<div>
<span tal:content="item_description"></span>
</div>
</div>
</tal:block>
</div>
</div>

Abçs

Natália

--- Em zope-pt@yahoogrupos.com.br <zope-pt%40yahoogrupos.com.br>, "Erico
Andrei" <[EMAIL PROTECTED]>
escreveu
>
> Natália,
>
> Por favor envie o código do portlet.
>
> Abs,
> EA
>
> On 5/25/07, Natalia Souza <[EMAIL PROTECTED]> wrote:
> >
> > Olá pessoal
> >
> > Estou com problemas com o CMFPublication. Não estou conseguindo
fazer
> > com que as portles apareçam na página. Já postei várias msgs,
mas acho
> > que não fui muito específica.
> >
> > É o seguinte: Instalei o Publicator sem problemas, e consegui
colocar
> > um portlet com o título notícias. Até aí tudo bem. O problema é
que
> > não consigo fazer com que outras portles apareçam. Até consigo
criá-
> > las pelo plone, mas elas não esão aparecendo na página. Tentei
criar
> > um novo template e inserir a referência em Properties
> > (here/portlet_modelo/macros/portlet), mas dá erro. Help-me!
> >
> > Abraços
> >
> > Natália
> >
> >
> >
>

Responder a