Fala Marcon,

> Utilizo a combinação Zope-2.9.6 e Plone 2.5.3 bundle, revisão 12939.
> A um tempo atrás, observamos um problema na data do plone, onde a hora
> estava sendo adicionada de 3, ou seja, nosso fuso não era reconhecido,
> estava como GMT-0. Googleando encontrei esta thread[1] e foi resolvido.
> 
> Hoje observamos um comportamento muito estranho sobre a informação da
> hora no plone, ele está adicionando uma hora a mais que o horário normal
> de verão(está em GMT-1), porém na ZMI é exibida a hora correta.
> 
> Alguém tem alguma dica?

interessante, semana passada eu havia comentado com o Sidnei que
esse havia sido o único ano que não tinha dado problema com o
horário de verão no Zope da UCS... :-P

Buenas, vamos ver se é o mesmo problema dos outros anos, faz o
seguinte, usando o python do Zope:

>>> import time
>>> time.tzname
('BRT', 'BRST')

Se no teu caso aparecer ('BRT', 'BRT') é porque o Python não está
conseguindo reconhecer/identificar o horário de verão.

Detalhe, mesmo que outras partes do sistema já reconheçam o BRST,
pode ser que o Python não reconheça em função de alguma pequena
inconsistência no arquivo .zic que gerou a zona.

Num sistema Debian-like (como o Ubuntu, por exemplo) basta instalar
o pacote 'tz-brasil', que ele atualiza o arquivo da timezone.

Em outros sistemas, basta seguir as instruções do alerta do CAIS:

http://www.rnp.br/cais/alertas/2007/cais-alr-20071005.html

Se não for nada disso, então é um novo problema que eu ainda não
tinha visto... :-)

HTH,

-- 

Dorneles Treméa
X3ng Web Technology
http://nosleepforyou.blogspot.com

Responder a