Pablo Nogueira escreveu:
> Fala grande Douglas (Mineiro),
> 
> Bixo você me quebrou um galho. Um dos links que você me mandou, fala sobre
> clock (hora do servidor)
> como sendo possível causa de problemas com a session. Verifiquei meu
> servidores e vi que um tá com a hora diferente do outro (Diferença de duas
> horas).  Ai foi que lembrei que aqui no trabalho agente tem um servidor NTP
> (Network Time Protocol) abilitei o serviço e bootei os dois servidores. Com
> isso eles ficaram sincronizados. O problema que eu tava tendo foi resolvido
> com esse detalhe de data e hora de servidor.
> 
> Obrigado a todos os outro membros da lista que me ajudaram  nesta tread,
> (Rodrigo, Xiru, Jean, Clayton, etc..).
> E mais uma lição aprendida. Agente quando configura um servidor nem presta
> atenção nestes detalhes. Mas é muito importante setar a hora do servidor
> adequadamente
> 
> Abraço a todos

Opa,

Show de bola que ajudou fi =)

Quando vi o lance relacionado a hora também achei muito interessante 
porque faz todo o sentido, e o que vc disse é verdade. Algumas vezes 
esses esquemas de servidor geram o maior problema, já tive um dor 
gigante de cabeça com shares nfs 'só' porque os users dos dois 
servidores que eu tava montando o share nao tinha uids iguais.

Mas é isso ae =)

> Em 21/01/08, Douglas Soares de Andrade <[EMAIL PROTECTED]> escreveu:
>>   Pablo Nogueira escreveu:
>>
>>> Opa Jean,
>>>
>>> Importei sim o tempstorage
>>>
>>> Minha zeo tá assim:
>>>
>>> <zeo>
>>> address 8100
>>> read-only false
>>> invalidation-queue-size 100
>>> # pid-filename $INSTANCE/var/ZEO.pid
>>> # monitor-address PORT
>>> # transaction-timeout SECONDS
>>> </zeo>
>>>
>>> %import tempstorage
>>> <temporarystorage temp>
>>> name temporary storage for sessioning
>>> </temporarystorage>
>>>
>>>
>>> <filestorage 1>
>>> path $INSTANCE/var/Data.fs
>>> </filestorage>
>>>
>>>
>>>
>>> <eventlog>
>>> level info
>>> <logfile>
>>> path $INSTANCE/log/zeo.log
>>> </logfile>
>>> </eventlog>
>>>
>>> <runner>
>>> program $INSTANCE/bin/runzeo
>>> socket-name $INSTANCE/etc/zeo.zdsock
>>> daemon true
>>> forever false
>>> backoff-limit 10
>>> exit-codes 0, 2
>>> directory $INSTANCE
>>> default-to-interactive true
>>> # user zope
>>> python /usr/local/bin/python2.4
>>> zdrun /usr/local/www/Zope29/lib/python/zdaemon/zdrun.py
>>>
>>> # This logfile should match the one in the zeo.conf file.
>>> # It is used by zdctl's logtail command, zdrun/zdctl doesn't write it.
>>> logfile $INSTANCE/log/zeo.log
>>> </runner>
>>>
>>>
>>> ----------------------------------------------------------
>>> A instancia conectada na zeo (instancia onde a session dá pau) tá assim:
>>>
>>> <zodb_db temporary>
>>> <zeoclient>
>>> server localhost:8100
>>> storage temp
>>> name zeostorage
>>> var $INSTANCE/var
>>> </zeoclient>
>>> mount-point /temp_folder
>>> container-class Products.TemporaryFolder.TemporaryContainer
>>> </zodb_db>
>>>
>>>
>>>
>>> # Other storage examples
>>> #
>>> # ZEO client storage:
>>> #
>>> <zodb_db main>
>>> mount-point /
>>> # ZODB cache, in number of objects
>>> cache-size 5000
>>> <zeoclient>
>>> server localhost:8100
>>> storage 1
>>> name zeostorage
>>> var $INSTANCE/var
>>> # ZEO client cache, in bytes
>>> cache-size 200MB
>>> # Uncomment to have a persistent disk cache
>>> #client zeo1
>>> </zeoclient>
>>> </zodb_db>
>> Oi Pablo,
>>
>> Parece que o seu problema é o mesmo descrito nesse link:
>>
>> http://www.nabble.com/KeyErrors-in-Zope-using-ZEO-td10436333.html
>>
>> E que tambem parece com esse:
>>
>> https://bugs.launchpad.net/zodb/+bug/114814
>>
>> E esse:
>>
>> http://www.opensubscriber.com/message/[EMAIL PROTECTED]/6712031.html
>>
>> E por fim, mas que mostra uma possível causa do problema (remota, mas
>> provavel):
>>
>> http://www.opensubscriber.com/message/[EMAIL PROTECTED]/5378268.html
>>
>> Valeu =)
>>
>>> Em 18/01/08, Jean Rodrigo Ferri <[EMAIL PROTECTED]<jeanferri%40gmail.com>>
>> escreveu:
>>>> Pablo Nogueira escreveu:
>>>>> Pessoal,
>>>> Olá Pablo,
>>>>
>>>>> Eu tenho uma ZEO e 7 instancias zope clients divididas em 2 maquinas
>>>>> diferentes.
>>>>> Na maquina que tem 4 instancias a SESSION funciona normalmente na
>> outra
>>>>> maquina não. Tudo muito estranho
>>>>>
>>>>> Eu pensei que o problema fosse com a montagem do temporary folder. Mas
>>>> em
>>>>> todas as instancias estão iguais:
>>>>>
>>>>> <zodb_db temporary>
>>>>> <zeoclient>
>>>>> server 192.168.32.86:8100
>>>>> storage temp
>>>>> name zeostorage
>>>>> var $INSTANCE/var
>>>>> </zeoclient>
>>>>> mount-point /temp_folder
>>>>> container-class Products.TemporaryFolder.TemporaryContainer
>>>>> </zodb_db>
>>>> Você registrou o tempstorage no zeo.conf?
>>>>
>>>> %import tempstorage
>>>> <temporarystorage temp>
>>>> name temporary storage for sessioning
>>>> </temporarystorage>
>>>>
>>>> Abraço,
>>>>
>>>> --
>>>> Jean Ferri
>>>>
>>>>
>>>
>>>
>> --
>> Douglas Soares de Andrade
>> ThreePointsWeb - www.threepointsweb.com
>> Python, Zope e Plone
>> Archlinux Trusted User - dsa
>> Quote: Old programmers never die; they exit to a higher shell.
>>
>>  
>>
> 
> 
> 


-- 
Douglas Soares de Andrade
ThreePointsWeb - www.threepointsweb.com
Python, Zope e Plone
Archlinux Trusted User - dsa
Quote: Old programmers never die; they exit to a higher shell.

Responder a