Olá,

Segui as instruções do manual do Archgenxml2 no site do plone para
gerar um ambiente de testes no meu produto, porém quando eu rodo o
teste, aparece uma saída de erro que não consigo identificar onde pode
haver problemas.

Fiz um modelo minimalista de um Produto no ArgoUML e mesmo assim
aparece o mesmo erro.

Aqui vai a saída

*****************************************************************
[EMAIL PROTECTED]:~/sandbox/atuario$ ./bin/instance test -m MeuProduto
Running tests at level 1
Installing CMFCore ... done (0.040s)
Installing CMFDefault ... done (0.019s)
Installing CMFCalendar ... done (0.052s)
Installing CMFTopic ... done (0.035s)
Installing DCWorkflow ... done (0.085s)
Installing CMFActionIcons ... done (0.033s)
Installing CMFQuickInstallerTool ... done (0.095s)
Installing CMFFormController ... done (0.411s)
Installing GroupUserFolder ... done (0.537s)
Installing ZCTextIndex ... done (0.081s)
Installing CMFPlone ... done (1.811s)
Installing Archetypes ... done (0.126s)
Installing ATContentTypes ... done (0.046s)
Installing ATReferenceBrowserWidget ... done (0.014s)
Installing CMFDynamicViewFTI ... done (0.013s)
Installing ExternalEditor ... done (0.023s)
Installing ExtendedPathIndex ... done (0.021s)
Installing ResourceRegistries ... done (0.017s)
Installing SecureMailHost ... done (0.014s)
Installing CMFPlacefulWorkflow ... done (0.022s)
Installing PasswordResetTool ... done (0.026s)
Installing PluggableAuthService ... done (0.037s)
Installing PluginRegistry ... done (0.020s)
Installing PlonePAS ... done (0.024s)
Installing kupu ... done (0.426s)
Installing CMFEditions ... done (0.032s)
Installing CMFDiffTool ... done (0.029s)
Installing PloneLanguageTool ... done (0.028s)
Installing MeuProduto ... done (0.048s)
Running Products.PloneTestCase.layer.PloneSite tests:
/home/silvio/sandbox/atuario/parts/zope2/lib/python/zope/configuration/xmlconfig.py:323:
DeprecationWarning: zope.app.annotation has moved to zope.annotation.
Import of zope.app.annotation will become unsupported in Zope 3.5
 __import__(arguments[0])
 Set up Products.PloneTestCase.layer.ZCML in 4.172 seconds.
/home/silvio/sandbox/atuario/parts/plone/PlonePAS/setuphandlers.py:39:
DeprecationWarning: portal_groups.getGroupIds is deprecated and will
be removed in Plone 3.5. Use PAS searchGroups instead
 existing = gtool.listGroupIds()
 Set up Products.PloneTestCase.layer.PloneSite
Traceback (most recent call last):
 File "./bin/instance", line 50, in ?
   plone.recipe.zope2instance.ctl.main(
 File
"/home/silvio/sandbox/atuario/eggs/plone.recipe.zope2instance-1.3-py2.4.egg/plone/recipe/zope2instance/ctl.py",
line 210, in main
   c.onecmd(" ".join(options.args))
 File "/home/silvio/sandbox/python2.4/lib/python2.4/cmd.py", line
219, in onecmd
   return func(arg)
 File
"/home/silvio/sandbox/atuario/eggs/plone.recipe.zope2instance-1.3-py2.4.egg/plone/recipe/zope2instance/ctl.py",
line 177, in do_test
   zope.testing.testrunner.run(defaults, args)
 File
"/home/silvio/sandbox/atuario/parts/zope2/lib/python/zope/testing/testrunner.py",
line 271, in run
   failed = not run_with_options(options)
 File
"/home/silvio/sandbox/atuario/parts/zope2/lib/python/zope/testing/testrunner.py",
line 433, in run_with_options
   setup_layers, failures, errors)
 File
"/home/silvio/sandbox/atuario/parts/zope2/lib/python/zope/testing/testrunner.py",
line 604, in run_layer
   setup_layer(layer, setup_layers)
 File
"/home/silvio/sandbox/atuario/parts/zope2/lib/python/zope/testing/testrunner.py",
line 692, in setup_layer
   layer.setUp()
 File "/home/silvio/sandbox/atuario/parts/plone/PloneTestCase/layer.py",
line 33, in setUp
   func(*args, **kw)
 File "/home/silvio/sandbox/atuario/parts/plone/PloneTestCase/setup.py",
line 167, in setupPloneSite
   base_profile, extension_profiles).run()
 File "/home/silvio/sandbox/atuario/parts/plone/PloneTestCase/setup.py",
line 214, in run
   self._setupProducts()
 File "/home/silvio/sandbox/atuario/parts/plone/PloneTestCase/setup.py",
line 302, in _setupProducts
   qi.installProduct(product)
 File
"/home/silvio/sandbox/atuario/parts/plone/CMFQuickInstallerTool/QuickInstallerTool.py",
line 405, in installProduct
   portal_setup.runAllImportStepsFromProfile('profile-%s' % profile)
 File "/home/silvio/sandbox/atuario/parts/plone/GenericSetup/tool.py",
line 322, in runAllImportStepsFromProfile
   result = self._runImportStepsFromContext(context, purge_old=purge_old)
 File "/home/silvio/sandbox/atuario/parts/plone/GenericSetup/tool.py",
line 1028, in _runImportStepsFromContext
   message = self._doRunImportStep(step, context)
 File "/home/silvio/sandbox/atuario/parts/plone/GenericSetup/tool.py",
line 987, in _doRunImportStep
   return handler(context)
 File "/home/silvio/sandbox/atuario/products/MeuProduto/setuphandlers.py",
line 73, in installQIDependencies
   qi.reinstallProducts([dependency])
 File
"/home/silvio/sandbox/atuario/parts/plone/CMFQuickInstallerTool/QuickInstallerTool.py",
line 622, in reinstallProducts
   omitSnapshots=omitSnapshots)
 File
"/home/silvio/sandbox/atuario/parts/plone/CMFQuickInstallerTool/QuickInstallerTool.py",
line 550, in installProducts
   omitSnapshots=omitSnapshots)
 File
"/home/silvio/sandbox/atuario/parts/plone/CMFQuickInstallerTool/QuickInstallerTool.py",
line 405, in installProduct
   portal_setup.runAllImportStepsFromProfile('profile-%s' % profile)
 File "/home/silvio/sandbox/atuario/parts/plone/GenericSetup/tool.py",
line 325, in runAllImportStepsFromProfile
   self._createReport(name, result['steps'], result['messages'])
 File "/home/silvio/sandbox/atuario/parts/plone/GenericSetup/tool.py",
line 1081, in _createReport
   self._setObject(name, file)
 File
"/home/silvio/sandbox/atuario/parts/zope2/lib/python/OFS/ObjectManager.py",
line 314, in _setObject
   v = self._checkId(id)
 File
"/home/silvio/sandbox/atuario/parts/zope2/lib/python/OFS/ObjectManager.py",
line 102, in checkValidId
   raise BadRequest, (
zExceptions.BadRequest: The id
"import-all-profile-Products.Archetypes_Archetypes-20080121135143.log"
is invalid - it is already in use.


Alguém já viu esse tipo de erro? Tem idéia do q pode estar errado?

Abs,

  Silvio


Responder a