Boa tarde

Estou a tentar migrar uns sites que tenho numa instância Plone 2.5.5
para Plone 3.1.1. Mas acontece que quando tento refazer o catálogo
dá-me o seguinte erro:

File
"/opt/Plone- 3.1/zeocluster/ parts/zope2/ lib/python/ Products/
PageTemplates/ utils.py" ,
line 68, in convertToUnicode
return unicode(source, encoding), encoding
UnicodeDecodeError: 'utf8' codec can't decode bytes in position
1263-1265: invalid data
2008-05-08 15:52:49 ERROR Zope.SiteErrorLog
Traceback (innermost last):
Module ZPublisher.Publish, line 119, in publish
Module ZPublisher.mapply, line 88, in mapply
Module ZPublisher.Publish, line 42, in call_object
Module Products.CMFPlone. CatalogTool, line 452, in manage_catalogRebui ld
Module Products.CMFPlone. CatalogTool, line 442, in clearFindAndRebuild
Module OFS.FindSupport, line 260, in ZopeFindAndApply
Module OFS.FindSupport, line 260, in ZopeFindAndApply
Module OFS.FindSupport, line 260, in ZopeFindAndApply
Module OFS.FindSupport, line 260, in ZopeFindAndApply
Module OFS.FindSupport, line 260, in ZopeFindAndApply
Module OFS.FindSupport, line 248, in ZopeFindAndApply
Module Products.CMFPlone. CatalogTool, line 432, in indexObject
Module Products.CMFPlone. utils, line 455, in base_hasattr
Module Products.CMFPlone. utils, line 466, in safe_hasattr
Module ZODB.Connection, line 761, in setstate
Module ZODB.Connection, line 819, in _setstate
Module ZODB.serialize, line 605, in setGhostState
Module Products.PageTempla tes.ZopePageTemp late, line 419, in
__setstate__
Module Products.PageTempla tes.utils, line 68, in convertToUnicode
UnicodeDecodeError: 'utf8' codec can't decode bytes in position
1263-1265: invalid data

Acontece que a maioria das soluções que tem na net dão quase sempre a
solução de se usar o sitecustomize. py, na instância Plone na
directoria site-packages, no qual eu já fiz isso mas até agora nada :(.

Caso alguém tenha uma solução diferente agradecia muito que partilha-se.

Cumprimentos,
Joaquim Carvalho

Responder a