Olá moçada,

Meu primeiro post aqui, tipo dei uma olhada não vi ninguem com esse
problema aqui no grupo então vai ai o problema pra quem pduer me ajudar.
Eu criei um formulario no ploneFormGen certinho e tudo mais...criei
zSqlMethod q insere os dados do formulario na banco e tb criei um
script que tb esta funcionando corretamente inserindo no banco..o
problema é que quando clico em enviar no formulario, aparece o
seguinte erro...

TypeError: pegar_do_formulario() takes exactly 4 arguments (0 given)
(Also, the following error occurred while attempting to render the
standard error message, please see the event log for full details:
name 'plone_context_state' is not defined)

tipo eu entendi +- o erro, fala q o pegar formulario tem 4 parametros
e ele nao esta recendo nenhum ou 0, e ai oq faço!?
vo postar o meu pegar pegar parametro pra casa tenha algo
errado...alguem me falar...
segue o pegar_formulario:

o parameters list dele é:
cliente,checador,numerodaproposta,valordaproposta

e depois vem o codigo:

# Pega as variáveis do Ambiente
################################################
request = container.REQUEST
RESPONSE =  request.RESPONSE

################################################
# Recebe os valores da Pagina
################################################
cliente = request.get('cliente')
checador = request.get('checador')
numerodaproposta = request.get('numerodaproposta')
valordaproposta = request.get('valordaproposta')

################################################
# Insere as informações no banco
################################################

context.insereir_banco(cliente=cliente,checador=checador,
numero_da_proposta=numerodaproposta,
valor_da_proposta=valordaproposta)

return "Adicionado com sucesso!"

agradeço desde já...valeu...
abração

Responder a