Dayana Santiago escreveu:
> Prezados colegas,
> 
> Estou tentando fazer o plone 2.5.5 enviar emails quando um determinado tipo
> de objeto for criado. Utilizo o título do objeto e outros atributos para
> compor o corpo da mensagem.
> 
> Para isso, pendurei um script na transição submit e fiz com que ela fosse
> disparada automaticamente a partir do estado visible.
> 
> No entanto, o que acontece é que no momento em que ainda estou no formulário
> de edição do objeto, já recebo um email, com o caminho do portal_factory e,
> obviamente sem título. Quando termino de preencher e salvo, recebo mais dois
> emails: um com caminho do portal_factory e outro na pasta em que estou
> criando o objeto. Em todos eles nenhum dos atributos é acessível e o id é
> sempre aquele temporário criado pelo plone.
> 
> Alguma idéia de outra forma de mandar o email ou de acessar os atributos
> para compor a mensagem?

Olá Dayana,

Seguinte, se vc está utilizando um tipo customizado (criado via AGX), vc
pode utilizar os gatilhos at_post_create / at_post_edit para enviar o email.

Caso seja um tipo normal, vc pode utilizar um script de workflow que ao
mudar para o estado published (publicado) ele dispara o email.

Uma sugestão é mudar o quanto antes para o Plone3, que já possui essa
funcionalidade através de Content Rules.

-- 
Douglas Soares de Andrade
-- ThreePointsWeb - www.threepointsweb.com
-- Python, Zope e Plone
== Archlinux Trusted User and Developer - dsa
** Quote: Old programmers never die; they exit to a higher shell.

Responder a