valeu a dica, mas eu ja tinha feito isso tambem. Alguns objetos ele nao
exporta, deve ser porque nao tem suporte ainda mesmo, so queria uma
confirmacao.

Para os collections por exemplo eu instalei o smartFolderImportExport e
funcionou legal.

Essa novidade do portal_setup ainda tem muito bug por exemplo com os objetos
"normais" mesmo (Folder, Document) que eu mando criar, so dando
update_catalog para eles ficarem publicados e com o titulo normal.

Infelizmente uma tecnica boa mas q nao funciona

flw

2008/11/21 Alexandre Marinho <[EMAIL PROTECTED]>

>   Cara tenta exportar um objeto desse tipo que você criou, usando o
> portal_setup, e ve como fica o arquivo gerado.
>
> --
> Alexandre Marinho
> Consultor Pleno
> ITEC/AL
>
> 2008/11/21 Maurício Victor <[EMAIL PROTECTED]>
>
>  é só uma referência pra mim ler.
>>
>> daqui 2 dias vai fazer 1 mes da pergunta.
>>
>> Se alguem quiser responder, ainda não resolvi...
>>
>> 2008/10/23 Maurício Victor <[EMAIL PROTECTED]>
>>
>> Alguém tem alguma referência a mais sobre o assunto?
>>>
>>> Isso é novo? É velho demais?
>>>
>>> 2008/10/21 Maurício Victor <[EMAIL PROTECTED]>
>>>
>>> Boa Tarde Pessoal, tudo bem?
>>>>
>>>>       estou tendo problemas com relação a utilização de profiles (plone
>>>> 2.5.5, zope 2.9.8), espero que alguém consiga me ajudar...
>>>>
>>>> Li o tutorial *"Make a product install a folder structure in the site"*no
>>>> plone.org (
>>>> http://plone.org/documentation/how-to/add-a-folder-structure-to-your-product),
>>>> gostei da idéia, abandonei o AppInstall para criar a estrutura inicial no
>>>> portal, comecei a utilizar o 'portal_setup', mas aí vieram os problemas:
>>>>
>>>> - criei a estrutura de pastas: profiles -> default -> structure  e segui
>>>> todo o figurino como manda o artigo, funcionou criar pastas do tipo 
>>>> 'Folder'
>>>> normalmente, mas para os tipos que eu criei (containers, herdam de 
>>>> ATFolder)
>>>> não funciona, a pasta é criada mas não com os atributos específicos que eu
>>>> preciso.  Procurei na net alguma informação mas só encontro esse artigo
>>>> sobre o assunto.
>>>>
>>>> - outro problema foi que para exibir corretamente o atributo 'Title' no
>>>> 'folder_contents' e em alguns 'portlets' foi necessário dar um
>>>> 'update_catalog', alguém sabe o porque disto?
>>>>
>>>> Só de passar alguma referência sobre este assunto já está bom demais...
>>>>
>>>> obrigado, um abraço
>>>>
>>>>
>>>> --
>>>> Maurício Victor
>>>> http://mauvictor.objectis.net
>>>>
>>>
>>>
>>>
>>> --
>>> Maurício Victor
>>> http://mauvictor.objectis.net
>>>
>>
>>
>>
>> --
>> Maurício Victor
>> http://mauvictor.objectis.net
>>
>
>  
>



-- 
Maurício Victor
http://mauvictor.objectis.net

Responder a