Olá pessoas,

O problema é o seguinte, estou desenvolvendo um produto que inclui um
novo tipo o qual possui um campo file. 
Esse novo tipo irá "substituir" o atfile que usamos atualmente. São
esperados mais de 10 mil arquivos a serem inseridos a medida que o
portal for crescendo.

Sabendo disso, usei como storage desse campo o FSS (versao 2.7.0)
segui as instruções e instalei no meu ambiente de desenvolvimento
(buildout).

O produto atualmente já funciona com o fss.

Em seguinda tentei instalar o fss numa copia do ambiente de produção,
que nao utiliza o buildout, e sim a versao ZEO UnifiedInstaller. Como
eu fiz:
1. Extrai a pasta iw/fss para lib do python do zope
2. Criei o arquivo lib/python/iw/fss/etc/plone-filesystemstorage.conf
3. Como em $HOME_INSTACE/etc nao existia o arquivo site.zcml e a pasta
package-includes segui as inscrucoes do five e as copiei os mesmos de
Producs/Five/skel
4. Em seguida, criei os asquivos iw.fss-configure.zcml e
iw.fss-meta.zcml, seguindo as intrucoes do FSS, e as coloquei na pasta
package-includes.

Ao termino, depois de reiniciar o zope, todos os plone sites
retornavam o erro: 
KeyError: '@@plone' (Also, the following error occurred while
attempting to render the standard error message, please see the event
log for full details: '@@plone')

Zope 2.9.8
Plone 2.5.5
Five 1.4.4
Python 2.4.4

e aí?

--
Alexandre Marinho
Consultor Pleno
ITEC/AL

Responder a