Ola Rodrigo,

O buildout baixa, compila e instala o squid (2.6) e cria o arquivo de
configuração do apache (que foi instalado pelo apt-get no ubuntu
server). (Ao final desse email copiei a configuração presente no
buildout.cfg).

Depois eu inicio o apache   

 /etc/init.d/apache2 restart

Crio as pastas do cache do squid (o binário esta na pasta bin da
instalação do Plone)

./bin/squid-instance -z

Daí , vez ou outra dá um erro de permissão na pasta, então acerto isso com:

chown -R nobody var/log/squid-*  var/squidstorage/
parts/squid-build/install/var/

Inicio o squid

./bin/squid-instance -x

E por último inicio o zope e o plone

./bin/startcluster

O comando netstat -ntl me garante que esta tudo no ar

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address        
State     
tcp        0      0 206.196.110.2:8100      0.0.0.0:*              
LISTEN    
tcp        0      0 206.196.110.2:7022      0.0.0.0:*              
LISTEN    
tcp        0      0 206.196.110.2:8080      0.0.0.0:*              
LISTEN    
tcp        0      0 206.196.110.2:80        0.0.0.0:*              
LISTEN    
tcp        0      0 206.196.110.2:3128      0.0.0.0:*              
LISTEN    
tcp        0      0 206.196.110.2:443       0.0.0.0:*               LISTEN



Os logs estarão na pasta var/log do próprio plone


As partes do buildout.cfg


[apacheconfig]
recipe = plone.recipe.apache:config
mainconfig = /etc/apache2/apache2.conf
bind = 80
backends =
   dominio.org:dominio.org:3128
zope2_vhm_map =
    dominio.org:/

[squid-build]
recipe = plone.recipe.squid:build
url = http://www.squid-cache.org/Versions/v2/2.6/squid-2.6.STABLE18.tar.gz

[squid-instance]
recipe = plone.recipe.squid:instance
bind = 127.0.0.1:3128
backends = 127.0.0.1:8080
cache-size = 256



Qualquer coisa em que puder ajudar...


[]s

Rafael






Rodrigo Leite escreveu:
> Rafael,
>
> como está configurado o Squid para o cache? Nós usamos aqui, mas,
> ultimamente, estamos com um problema imenso. Sempre tem caído, pois
> creio que o Squid e o Plone  não estão configurados como deveriam.
>
> Se puder dar uma ajuda com isto, agradecerei.
>
> Rodrigo Leite
>
> ------------------------------------------------------------------------
> *De:* rafael <rafaelcro...@gmail.com>
> *Para:* simonemedeirosm <simonemedei...@gmail.com>;
> zope-pt@yahoogrupos.com.br
> *Enviadas:* Sexta-feira, 27 de Março de 2009 18:12:23
> *Assunto:* [zope-pt] Re: Apache
>
> Simone,
>
> Você usa o buildout para instalar o Plone?
> Se você usa, pode tentar acrescentar no seu buildout uma sessão (não
> esquece de por uma linha no parts= apacheconfig
>
> [apacheconfig]
> recipe = plone.recipe. apache:config
> mainconfig = /etc/apache2/ apache2.conf
> bind = 80
> backends =
> exemplo.org: inverta.org: 8080
> zope2_vhm_map =
> exemplo.org: /
>
> Se o caminho da configuração do seu apache for /etc/apache2/ , ele já
> vai gerar uma configuração pro seu apache e instalá-la automaticamente.
> (ela ficará na pasta parts/apacheconfig/ etc/conf. d/seusiteapachec onfig
>
> Qualquer dúvida me avise. Eu aqui,além do apache uso o squid para cache...
>
> Abraços,
>
> Rafael
>
> simonemedeirosm escreveu:
> > Olá Rafael, vi no forum que você implementou o site com o uso do
> apache, gostaria de saber que configuração é preciso fazer no zope e
> no apache para a integração de ambos. Caso possas enviar os arquivos
> de configuração, agradeço.
> >
> > Obrigada,
> > Simone
> >
> >
> >
>
>
> ------------------------------------------------------------------------
> Veja quais são os assuntos do momento no Yahoo! + Buscados: Top 10
> <http://br.rd.yahoo.com/mail/taglines/mail/*http://br.maisbuscados.yahoo.com/>
> - Celebridades
> <http://br.rd.yahoo.com/mail/taglines/mail/*http://br.maisbuscados.yahoo.com/celebridades/>
> - Música
> <http://br.rd.yahoo.com/mail/taglines/mail/*http://br.maisbuscados.yahoo.com/m%C3%BAsica/>
> - Esportes
> <http://br.rd.yahoo.com/mail/taglines/mail/*http://br.maisbuscados.yahoo.com/esportes/>
>
> 

Responder a