Eu sempre instalei o plone via ZopeSkel + buildout.

Em 12 de fevereiro de 2010 09:50, Luciano Pacheco <lucm...@gmail.com>escreveu:

>
>
> Erick,
>
> Seguem comentários abaixo.
>
> Grato,
>
> 2010/2/11 erick <erick_gall...@hotmail.com>
>
>> Agradeço a ajuda mais um vez Vanderson.
>> Seguem as mensagens apresentadas.
>>
>> ----------------------------------------------------------------------
>> er...@----:~/Documentos$ sudo python2.4 ez_setup.py
>> Downloading
>> http://pypi.python.org/packages/2.4/s/setuptools/setuptools-0.6c11-py2.4.egg
>> Processing setuptools-0.6c11-py2.4.egg
>> creating /usr/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg
>> Extracting setuptools-0.6c11-py2.4.egg to /usr/lib/python2.4/site-packages
>> Adding setuptools 0.6c11 to easy-install.pth file
>> Installing easy_install script to /usr/bin
>> Installing easy_install-2.4 script to /usr/bin
>>
>> Installed /usr/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg
>> Processing dependencies for setuptools==0.6c11
>> Finished processing dependencies for setuptools==0.6c11
>>
>> ----------------------------------------------------------------------
>>
>> er...@----:~/Documentos$ sudo easy_install-2.4 PIL
>> --------------------------------------------------------------------
>>
>> *** TKINTER support not available (Tcl/Tk 8.5 libraries needed)
>> --- JPEG support available
>> --- ZLIB (PNG/ZIP) support available
>> --- FREETYPE2 support available
>> --- LITTLECMS support available
>> --------------------------------------------------------------------
>>
> [...]
>
>> Finished processing dependencies for PIL
>>
>> ----------------------------------------------------------------------
>>
>> Aparentemente tudo ocorreu corretamente.
>> Então fiz um teste rápido.
>>
>> er...@----:~$ python2.4
>> Python 2.4.6 (#2, Jan 21 2010, 23:45:25)
>> [GCC 4.4.1] on linux2
>> Type "help", "copyright", "credits" or "license" for more information.
>> >>> import _imaging
>> >>>
>>
>> A importação da mostra que a PIL está instalada corretamente, no entanto
>> na instalação o erro persiste.
>>
>
> Perfeito, você tem o PIL no python 2.4 do seu sistema.
>
>
>> ----------------------------------------------------------------------
>>
>> er...@---:~$ sudo ./install.sh standalone
>> Stand-Alone Zope Instance selected
>>
>> Detailed installation log being written to
>> /home/erick/Downloads/Plone-3.3.4-UnifiedInstaller/install.log
>>
>> zlib installation: no
>> libjpeg installation: no
>> Root install method chosen
>>
>> Installing Plone 3.3.4 at /usr/local/Plone
>>
>> Skipping zlib compile and install
>> Skipping libjpeg compile/install
>> Skipping readline compile/install
>> Python found at /usr/local/Plone/Python-2.4/bin/python; Skipping Python
>> install.
>>
>
> Aqui você pode ver que ele não está usando o seu python do sistema, ele
> está usando um python próprio da sua instalação via UnifiedInstaller.
>
> Remove esse cara: /usr/local/Plone e faz a instalação novamente.
>
> Pois na primeira vez que você instalou, o PIL deu problema na compilação
> por causa da ausência dos headers da zlib
>
> [....]
>
>> >
>> >Passei por esse mesmo problema aqui. No meu caso foi um CentOS 5.4
>> >x86_64.
>> >
>> >O que resolveu foi instalar os pacotes: libjpeg-devel-6b-37.i386,
>> >freetype-devel-2.2.1-21.el5_3.i386,
>> >freetype-devel-2.2.1-21.el5_3.x86_64,libjpeg-devel-6b-37.x86_64,
>> >zlib-devel-1.2.3-3.i386 e zlib-devel-1.2.3-3.x86_64.
>>
> [...]
>
>> Esses pacotes você baixou um a um?
>> Pois não os encontro nos repositórios.
>>
>
> Esses nomes são de pacotes .rpm utilizados no CentOS, você precisa dos
> nomes dos pacotes no Ubuntu.
>
>
>>  --- Em zope-pt@yahoogrupos.com.br, Vanderson Mota dos Santos
>> <vanderson.m...@...> escreveu
>> >
>> > tente:
>> >
>> > apt-get install python2.4-dev zlib1g-dev
>>
>
> Aqui está o nome de alguns pacotes para Ubuntu :-) Provavelmente esse
> zlib1g-dev resolva o seu problema de compilação do PIL durante a instalação
> do UnifiedInstaller.
>
> Outro pacote que é bom você dar uma olhada é o libjpeg-dev (não sei o nome
> exato), pois se você não tiver esse pacote, o seu PIL ficará sem suporte a
> jpg e ao subir uma imagem .jpg no Plone vai dar erro.
>
> Para gerenciar os pacotes em linha de comando eu costumo utilizar o *
> aptitude*, que eu acho mais fácil para ficar navegando nos pacotes. O
> aptitude é o Synaptic da linha da linha de comando. ;-)
>
> Comandos do aptitude:
> */*  # permite fazer buscas
> *+* # marca o pacote para instalação
> *-*  # marca o pacote para remoção
> *=* # marca o pacote para manter a versão (sem atualizar)
> *g* # go! tipo um: "Já marquei tudo que eu queria, agora pode prosseguir",
> ele vai fazer um resumo do que será feito, deopis é só apertar *g* de novo
> (ou *q* para voltar)
> *q*  # volta, se estiver no primeiro nível da árvore de pacotes ele irá
> sair
> *u*  # update (atualiza os dados dos pacotes e repositórios)
> *U*  # upgrade (marcar os pacotes que tem atualização)
> *F10* # acessa os menus da janela, mas eu nunca uso :-)
>
> Até mais,
> --
> Luciano Pacheco
> blog.lucmult.com.br
>
>  
>



-- 
Vanderson Mota dos Santos

Responder a