[Tim Peters]
>> I get a failure today running the unit and functional tests in the same
>> run:
>>
>> """
>> FAIL: testModuleListView (zope.app.apidoc.browser.ftests.APIDocTests)
>> ...
>>   File "C:\Code\Zope3\src\zope\app\testing\functional.py", line 371,
>> in checkForBrokenLinks
>>     self.fail("%s contains broken links:\n" % path
>>   File "C:\python23\lib\unittest.py", line 270, in fail
>>     raise self.failureException, msg
>> AssertionError: /++apidoc++/modulelist.html contains broken links:
>>   /++apidoc++/./++preferences++/apidoc/@@apidocMenu.html:      
>> ForbiddenAttribute: ('__getitem__',
>> <zope.app.preference.preference.PreferenceGroup object at 0x07AEEB10>)
>> """
>> However, the test passes if I leave the unit tests out of the run
>> (i.e., test.py -f).

[Stephan Richter]
> This is my fault. I can reproduce the issue. What's particularly strange is
> that I can just run the tests in zope.app.apidoc to reproduce the problem. I
> thought I have to run at least the zope.app.preference tests too. Mmmh, I
> have to dig a while to figure out what's going on.

Hmm.  I cannot reproduce the problem that way, although I'm not
exactly sure what "just run the tests in zope.app.apidoc" means to
you.  This is what it means to me (on WinXP):

C:\Code\Zope3>\python23\python.exe test.py -vvf zope.app.apidoc
Configuration file found.
Running FUNCTIONAL tests at level 1
Running FUNCTIONAL tests from C:\Code\Zope3
Parsing ftesting.zcml
testContentsView (zope.app.apidoc.browser.ftests.APIDocTests) ... ok
testIndexView (zope.app.apidoc.browser.ftests.APIDocTests) ... ok
testMenu (zope.app.apidoc.browser.ftests.APIDocTests) ... ok
testModuleListView (zope.app.apidoc.browser.ftests.APIDocTests) ... ok
testClassDetailsView
(zope.app.apidoc.codemodule.browser.ftests.CodeModuleTests) ... ok
testFunctionDetailsView
(zope.app.apidoc.codemodule.browser.ftests.CodeModuleTests) ... ok
testMenu (zope.app.apidoc.codemodule.browser.ftests.CodeModuleTests) ... ok
testMenuCodeFinder
(zope.app.apidoc.codemodule.browser.ftests.CodeModuleTests) ... ok
testModuleDetailsView
(zope.app.apidoc.codemodule.browser.ftests.CodeModuleTests) ... ok
testTextFileDetailsView
(zope.app.apidoc.codemodule.browser.ftests.CodeModuleTests) ... ok
testZCMLFileDetailsView
(zope.app.apidoc.codemodule.browser.ftests.CodeModuleTests) ... ok
C:\Code\Zope3\src\zope\app\apidoc\codemodule\browser\introspector.txt ... ok
testInterfaceDetailsView
(zope.app.apidoc.ifacemodule.ftests.InterfaceModuleTests) ... ok
testMenu (zope.app.apidoc.ifacemodule.ftests.InterfaceModuleTests) ... ok
testMenu (zope.app.apidoc.utilitymodule.ftests.UtilityModuleTests) ... ok
testUtilityDetailsView
(zope.app.apidoc.utilitymodule.ftests.UtilityModuleTests) ... ok
testDirectiveDetailsView
(zope.app.apidoc.zcmlmodule.ftests.ZCMLModuleTests) ... ok
testMenu (zope.app.apidoc.zcmlmodule.ftests.ZCMLModuleTests) ... ok

----------------------------------------------------------------------
Ran 22 tests in 16.000s

OK

C:\Code\Zope3>
_______________________________________________
Zope3-dev mailing list
Zope3-dev@zope.org
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com

Reply via email to