> [mailto:[EMAIL PROTECTED] On 
> Behalf Of Florian Lindner
> Sent: Thursday, April 21, 2005 10:18 PM
> To: Stephan Richter;
> Subject: Re: [Zope3-dev] Question and maybe enhancement of 
> theHomeFolderManager

> I've started to fork you Homefolder Manager and get a 
> conflicting error:
> zope.configuration.config.ConfigurationConflictError: Conflicting 
> configuration actions
>   For: ('utility', <InterfaceClass 
> 'IHomeFolderManager')
>     File 
> "/home/florian/Desktop/zope/lib/python/CS/Homefolder/configure.zcml", 
> line 74.2-78.8
>         <browser:tool
>             interface="CS.Homefolder.interfaces.IHomeFolderManager"
>             title="CS Home Folder Manager"
>             description="A CS customized version of the Home 
> Folder Manager"
>             />
>     File 
> "/home/florian/Zope3/src/zope/app/homefolder/configure.zcml", line 
> 74.2-78.8
>         <browser:tool
>             interface=".interfaces.IHomeFolderManager"
>             title="Home Folder Manager"
>             description="A Principal Home Folder Manager"
>             />
> Why do they conflict? The interface is different, only the 
> last part is equal?

Ups, that's the problem. Only the interface class name is used
as the name for the named utility.


def tool(_context, interface, title, description=None,
         folder="tools", unique=False):
    name = interface.getName()
    permission = 'zope.ManageContent'
    tool = ToolConfiguration(interface, title, description, unique)

    ifaceDirective(_context, interface, IToolType)
    utility(_context, IToolConfiguration, tool,
            permission=permission, name=name)

I don't know if this is good or bad. But it seams to be a problem
in your case.

Hm, another question is, will the tool concept stay as the deault
registration concept or do we refactor this part a second time.
I think Stephan did a great job with the blow-service-branch work.
But I think this was not the last changes. Right now we have a
little mess in the registration concept, because the
use a much more implicit registration then other utilities.
This ends in a unusable "tool" registration for the authentication utility.

I recomend to use another name for your interface class name right now.
And propose a second iteration on the registration concept after 
the release 3.1.


Roger Ineichen

> Thx,
> Florian
> _______________________________________________
> Zope3-dev mailing list
> Unsub: 

Zope3-dev mailing list

Reply via email to