Hello,
I am starting with Zope 3, so far I like it :)
But going thru the Chapter 3 of the Zope 3 book, I've got an error and I don't 
know how to solve it (note, I am running Zope 3.1.0b1).
Here's the whole errror:

[EMAIL PROTECTED] ~/zope/bin $ ./runzope
/opt/Zope-3.1.0b1/lib/python/zope/configuration/fields.py:417: UserWarning: 
You did not specify an i18n translation domain for the 'description' field 
in /home/pupeno/zope/lib/python/book/messageboard/configure.zcml
  warnings.warn(
Traceback (most recent call last):
  File "./runzope", line 48, in ?
    run()
  File "./runzope", line 44, in run
    main(["-C", CONFIG_FILE] + sys.argv[1:])
  File 
"/home/pupeno/Temporary/Download/Zope-3.1.0b1/build/lib.linux-i686-2.3/zope/app/server/main.py",
 
line 58, in main
    setup(load_options(args))
  File 
"/home/pupeno/Temporary/Download/Zope-3.1.0b1/build/lib.linux-i686-2.3/zope/app/server/main.py",
 
line 169, in setup
    zope.app.appsetup.config(options.site_definition)
  File 
"/home/pupeno/Temporary/Download/Zope-3.1.0b1/build/lib.linux-i686-2.3/zope/app/appsetup/appsetup.py",
 
line 52, in config
    context = xmlconfig.file(file, execute=execute)
  File 
"/home/pupeno/Temporary/Download/Zope-3.1.0b1/build/lib.linux-i686-2.3/zope/configuration/xmlconfig.py",
 
line 557, in file
    context.execute_actions()
  File 
"/home/pupeno/Temporary/Download/Zope-3.1.0b1/build/lib.linux-i686-2.3/zope/configuration/config.py",
 
line 615, in execute_actions
    for action in resolveConflicts(self.actions):
  File 
"/home/pupeno/Temporary/Download/Zope-3.1.0b1/build/lib.linux-i686-2.3/zope/configuration/config.py",
 
line 1522, in resolveConflicts
    raise ConfigurationConflictError(conflicts)
zope.configuration.config.ConfigurationConflictError: Conflicting 
configuration actions
  For: ('protectName', <class 'book.messageboard.message.Message'>, 
'__setitem__')
    File "/home/pupeno/zope/lib/python/book/messageboard/configure.zcml", line 
15.2-21.2
        <content class=".message.Message">
          <implements 
interface="zope.app.annotation.interfaces.IAttributeAnnotatable" />
          <implements 
interface="zope.app.container.interfaces.IContentContainer" />
          <require permission="zope.ManageContent" 
interface=".interfaces.IMessage" />
          <require permission="zope.ManageContent" 
interface=".interfaces.IMessageContainer" />
          <require permission="zope.ManageContent" 
set_schema=".interfaces.IMessage" />
        </content>
    File "/home/pupeno/zope/lib/python/book/messageboard/configure.zcml", line 
15.2-21.2
        <content class=".message.Message">
          <implements 
interface="zope.app.annotation.interfaces.IAttributeAnnotatable" />
          <implements 
interface="zope.app.container.interfaces.IContentContainer" />
          <require permission="zope.ManageContent" 
interface=".interfaces.IMessage" />
          <require permission="zope.ManageContent" 
interface=".interfaces.IMessageContainer" />
          <require permission="zope.ManageContent" 
set_schema=".interfaces.IMessage" />
        </content>
[EMAIL PROTECTED] ~/zope/bin $

I've commented out
<require permission="zope.ManageContent" 
interface=".interfaces.IMessageContainer" />
and Zope started, but I do not have the option to add a message board.
Does anybody know what am I doing wrong ?
Thank you.
-- 
Pupeno <[EMAIL PROTECTED]> (http://pupeno.com)
Reading ? Science Fiction ? http://sfreaders.com.ar

Attachment: pgpvwIt97nRVD.pgp
Description: PGP signature

_______________________________________________
Zope3-dev mailing list
Zope3-dev@zope.org
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com

Reply via email to